VW Jetta TDI lack of power and check engine light

Taggs

Active member
Joined
Nov 28, 2004
TDI
Jetta, 2001, Blue
Yesterday I purchased a 2001 Jetta TDI. On the 150 mile treck home the check engine light came on and I also noticed that the car has no power over 60 miles per hour. Can anyone help me with my problem?
 

dzlchef

Veteran Member
Joined
Jun 12, 2004
Location
Redondo Beach, CA
TDI
Previously 02 Jetta TDI
First off, update your profile with location and maybe there is someone close by to help. You'll need to get the CEL code read first and that will help. Look at the VAG-COM listing at the top of the page and contact someone close to you to help. You can also go to an Autozone and have the code read by free from them and post it here for more help. Right now you've given not enough information to give a very good diagnosis.

Any other known history of the car would be helpful as well.

Does your cruise control work? Any other symptoms besides a lack of power?
 

Taggs

Active member
Joined
Nov 28, 2004
TDI
Jetta, 2001, Blue
I purchased the car used with 53,000 miles in Verginia. I live in Bucks County PA. I did pull the intake hose off and noticed a lot of build up. The turbo on the car just seems to shut off at 60. I will check into the codes.
 

Rustynuts

Veteran Member
Joined
Jun 13, 2004
Location
Richmond, North England
TDI
VW Jetta 2.0ltr Sport TDI
Do you know where the MAF sensor is? The pipe between the air filter and the turbo has an electrical sensor clipped in the side of it, this is the Mass Air Flow sensor. Try unplugging this, possibly with the aid of a small screwdriver to release the holding clip, and see if you get any improvement. If so, then the MAF is failing. Disconnecting it gives the ECU a set value to work from and is usually an improvement over the failed sensor.

It could also be that the inlet is severely clogged. There have been a couple of threads recently where people have reported lack of power and unable to rev over about 3000 rpm. Try a search for "clogged intake" (include the " ") and see what you find. Here's one I found.
 

weedeater

Top Post Dawg
Joined
Mar 17, 2001
Location
Reston, VA
TDI
Jetta, 2001, Baltic Green
also, check all the vacuum hoses. I had one fall off and the result was the same: CEL and lack of power.
 

Taggs

Active member
Joined
Nov 28, 2004
TDI
Jetta, 2001, Blue
Thanks to all for the tips. I will start trying your suggestions tomorrow.
 
Top