VSS Wiring for cluster and ECU - HELP!

2slotdi

Member
Joined
Mar 24, 2024
Location
Ridgecrest California
TDI
98 Jetta TDI (daily)
Hello everyone, im currently running into an issue swapping from my old socketed AHU ECU to a newer EDC15 from an '03 ALH. I'm also trying to swap my cluster from the mk3 to the mk4 at the same time. The issue I'm running into is I can't find any information on how I connect the signal wire from the VSS. I have 1 wiring diagram that says the ECU gets its signal from pin 20, but another that says that same wire is just connected to the cluster. Do I need to splice the VSS wire into just the ECU, or do I need to splice it into both the cluster and the ECU?

Thanks in advance!
 

CasaEd

Veteran Member
Joined
Mar 18, 2017
Location
Portugal
TDI
VW Passat TDi B4, VW Passat TDi B4 GL, VW Passat B3 PD AWX Conversion
The way it should be wired is speed signal go's to instrument cluster, speed signal wire comes out of instrument cluster and go's to ECU. What is the base car, Golf 3 ?
 

2slotdi

Member
Joined
Mar 24, 2024
Location
Ridgecrest California
TDI
98 Jetta TDI (daily)
Thank for your response! The base car is a Mk3 Jetta TDI. When you say it goes to the cluster, then to the ECU, are they both connected to the VSS? Or does the cluster send the signal to the ECU on a separate signal wire?
 

caffeine

Veteran Member
Joined
Jan 4, 2021
Location
B.C., Canada
TDI
03 Allroad w/04 BHW/02X conversion, 00 ALH Jetta
Thank for your response! The base car is a Mk3 Jetta TDI. When you say it goes to the cluster, then to the ECU, are they both connected to the VSS? Or does the cluster send the signal to the ECU on a separate signal wire?
VSS is only wired directly to the cluster. The cluster outputs a speed signal to the ECU either through a dedicated output (don't know the pin off the top of my head) or over CAN bus.
 

Alchemist

Veteran Member
Joined
Nov 3, 2007
Location
Lethbridge, Alberta
TDI
'04 ALH Golf
Here is what I have in my notes on VSS wiring for MKIV.

Fuse 7 supplies power to the VSS Pin 1 on a Black/Green wire via T14A-2 (14 pin connector in the plenum)
VSS Signal from pin 2 to cluster Green Connector Pin 28 via T14A-3
VSS Ground Pin 3 Brown wire to T14A-7 (To cluster?)
Vss Signal from cluster to ECU T121-20 Via T10 Orange on Blue /White wire.

Vss Signal goes from VSS sensor into the cluster and comes out of the cluster before going to the ECU.
 

2slotdi

Member
Joined
Mar 24, 2024
Location
Ridgecrest California
TDI
98 Jetta TDI (daily)
Sweet! I'll try to find that other wire in my donor car later this week. I'll keep you all updated and thank you so much for your responses!
 

2slotdi

Member
Joined
Mar 24, 2024
Location
Ridgecrest California
TDI
98 Jetta TDI (daily)
So here's a quick update on the progress with this swap. I've decided I'm keeping the mk3 gauge cluster and just spliced the ALH ECU speedo input to the factory speedometer wire in the harness. I ended up just doing an immo delete and the car is now put back together. However the speedo doesn't work at all. I don't know if this is because I'm using a Mk3 gauge cluster, or maybe I unplugged something next to the fuse block when I was putting the dash back in. Can any of you point me in the right direction to solve this? Thank you
 

GTiTDi

TDIClub Enthusiast, Macht Schnell! Vendor , w/Busi
Joined
Oct 18, 2010
Location
3 Spruce st Wareham, gateway to Cape Cod Massachus
TDI
'91 GTI CJAA swap,'02 Jetta wagon ALH swap, '03 GTI 1.8T rally car, '03 Sprinter 3500
Are you having issues with it still? I have a different issue with my swap and a mk3 cluster. My speedometer works fine but it's output to the ecu/cruise control is not.
 

2slotdi

Member
Joined
Mar 24, 2024
Location
Ridgecrest California
TDI
98 Jetta TDI (daily)
Are you having issues with it still? I have a different issue with my swap and a mk3 cluster. My speedometer works fine but it's output to the ecu/cruise control is not.
So to answer your question, no I'm not. The problem came from the fact that the VSS wasn't getting any power from the (now not used) 109 relay. So what I ended up doing was just splicing the power from the reverse switch up to the 12v pin on the VSS and it works flawless now! I would think if your speedo works, then your VSS is good and gets power. I'd suggest looking into the fuse box area or behind the headlight switch and look for a junction box, there should be a blue section with 2 blue/white wires connected. IIRC that is where the signal from the speedo and VSS get sent off to the ECU
 

turbodieseldyke

Veteran Member
Joined
Jun 6, 2010
Location
Free Mustache Rides
TDI
98 jetta
it goes from VSS -> T28a/3 (orb) -> G1/11 -> U1/11 -> T28/27 (cluster)
then from cluster T28/7 -> U2/2 -> W/1 -> TV13 -> T68/65 (ecu)

I believe the blue junction box is before the cluster
 

GTiTDi

TDIClub Enthusiast, Macht Schnell! Vendor , w/Busi
Joined
Oct 18, 2010
Location
3 Spruce st Wareham, gateway to Cape Cod Massachus
TDI
'91 GTI CJAA swap,'02 Jetta wagon ALH swap, '03 GTI 1.8T rally car, '03 Sprinter 3500
In my case, it's not a matter of wiring, it's a matter of what the CR edc17 unit wants to see rather than what is being provided. I have scoped and verified both outputs and I have healthy signals.
 
Top