Turn indicator issues

Hwycruiser

Well-known member
Joined
Jul 27, 2014
Location
DFW, Texas
TDI
2002 Black Golf GLS
Took a highway trip last weekend and with a lot of traffic was changing lanes frequently. I am one to use my turn indicator (half way) to indicate a lane change and I experienced my turn indicator sound continue to click after the lever was return to the off position. I also experience a short lag in power when I initially use my cruise control toggle to accelerate. Any opinions as to the cause of the odd behavior? Is it a worn out turn lever or internal electrical contact? I have seen turn indicator levers for sale (not sure if they are equipped with cruise control functions). Do you think it is it an easy fix or a complicated one that should just be ignored?

PS- When I got back home I finally got around to installing a new front door lock that I got last year. It corrected a lot of annoying issues I was having. I don't think the faulty door latch was causing the problem but have not driven enough yet to know.
 
Last edited:

BobnOH

not-a-mechanic
Joined
May 29, 2004
Location
central Ohio
TDI
New Beetle 2003 manual
Often it is the grease in the switch. Over time it picks up enough flecks to conduct. If you can get at it, try some electrical contact cleaner.
 

Dh4276

Veteran Member
Joined
Jul 22, 2019
Location
South Carolina
TDI
2006 Golf GLS TDI, BEW
You can get the arm with cruise easily, it’s not that hard of a job to change it out either.


Sent from my iPhone using Tapatalk
 
Top