That's life or another issue with VW Bluetooth

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
In addition to omitting the Play/Pause control on the steering wheel, there seems to be a more serious issue here.

While listening to one of my Sinatra favs: "Thats life", while having my Galaxy SII paired through VW's own BT implementation, I noticed that the music sounded weird.

In the beginning the Old Blue Eyes goes "that's life !" and then the girls in the chorus repeat that, at may be 80% of the volume.

Guess what, you can not even hear the chorus at all. As if VW's BT somehow clips one of the 2 stereo channels down to almost nothing. Nothing I do with settings in VW menus or on my phone seems to help. Same issue when I use a different player on the phone.

When I play the same tune using same player, but going through "Kensington LiquidAux" bluetooth adapter, using VW's "Aux" input, it plays perfectly, no issues at all.

The issue, of course, is not specific to this tune, all of the music sounds weird like that :confused:.

On a funny note I drove from NJ to PA yesterday, while listening to music through VW's bluetooth and got to PA (100 mile drive) with a headache that I couldn't explain ... now I know it is due to listening to only 1/2 of what was on those tracks.

It is not like the music sounds like out of balance (coming out of left or right speaker) but it seems that VW's BT A2DP implementation somehow manages to clip one of the stereo channels coming in, then it amps whatever is left, mixes it and dishes it out through car speakers.

*** !?

To preempt the "tough luck, burn your music to CDs and/or copy to an SD card etc etc" comments :) , I luvez me music on me phone - this way she travels with me, no matter the car I use ....
 

Diesel Ed

Well-known member
Joined
Jan 23, 2012
Location
Fairfax MN
TDI
2012 Passat TDI SE (DSG); 09 Jetta TDI (DSG, Sedan)
I got nothing. That sucks. My phone works fine in our Passat, but SD cards are cheap and easy to move music onto. Phone for the rest of the cars, SD for the Passat.

Sent from my DROID BIONIC using Tapatalk
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
My situation sux big time. Imagine what would it take to even explain the issue to the techs. Not sure if it is defective BT module or they butchered the A2DP by design ...

I am back to the Kensington LiquidAux kit.

Can folx with BT-connected smart phones try to reproduce ? Ideally, a stereo track where you can easily see if a channel is outta whack or not.

Again, it does connect and play and everything, but it seems like they clip one of the stereo channels.
 

APT

Veteran Member
Joined
Mar 20, 2012
Location
Metro Detroit
TDI
2012 Passat SEL
The Cars, "Moving in Stereo" is an easy test, if not a great song. I'll have to get that on my phone to try. I have not noticed any stereo separating issues yet.
 

740GLE

Top Post Dawg
Joined
Aug 19, 2009
Location
NH
TDI
2015 Passat SEL, 2017 Alltrack SE; BB 2010 Sedan Man; 2012 Passat,
VW will point to your phone and wipe your hands, bluetooth is the next RS232 nonstandard/standard.
 

peace_of_soul

Well-known member
Joined
Jul 17, 2008
Location
Indianapolis, IN
TDI
2000 Jetta, 2012 Passat
Our BT seems to work great, playing music and doing calls, with the wife's iPhone but won't play music from my Galaxy. I think it's a phone issue, not a VW BT issue.
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
The phone plays fine through Bluetooth via Kensington LiquidAux kit,
but not via built-in VW BT.

Again, you won't notice an issue unless you look for it, everything works just fine and music does play too, it's just one of the channels seems to be clipped.

So:

Galaxy SII -> BT (A2DP) -> Kensington BT adapter -> VW "Aux" input is 100%
but
Galaxy SII -> BT (A2DP) -> VW BT is 50% ... . so to speak
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
Apt, thanks for the find .

Meesa not alone no more ... the chorus of mono-voices is growing, so to speak :) .
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
Called VW and logged a complaint ... they seem to be aware of the issue
 

eatpasta

Veteran Member
Joined
Apr 5, 2011
Location
Santa Barbara, Ca
TDI
2012 Passat
I seriously doubt a cel phone could transmit 44.1 kHz quality sound via bluetooth.
My car just play ringtones off my phone when I get in - and yes they sound like crap.

Just wire up, quality is worth it.
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
I am hard pressed to tell the difference between wire and a _working_ BT :)
Not having to plug any wires in .... priceless !
 

740GLE

Top Post Dawg
Joined
Aug 19, 2009
Location
NH
TDI
2015 Passat SEL, 2017 Alltrack SE; BB 2010 Sedan Man; 2012 Passat,
throughput of BT is 2.1 Mbit/s more than enough for a simple MP3 at 128/256kbs.
 

APT

Veteran Member
Joined
Mar 20, 2012
Location
Metro Detroit
TDI
2012 Passat SEL
This seems to be a RCD issue, not the RNS510. I'm not sure it it is the RCD510 or 315 only though.
 

Niner

duplicate account, banned
Joined
Jun 3, 2011
My phone does it too... Samsung Galaxy S2... completely ruined Joe Walsh "Closet Queen/Bolero" right before where Bolero portion starts. I think you'd need stereo bluetooth channels, two from the phone, two to pick up on the radio, when bluetooth is designed for a mono voice on your phone in this app. RCD510 also. Sounds great, however, off of the 8 gig SD card, perfect.
 
Last edited:

gcodori

Veteran Member
Joined
Mar 16, 2005
Location
northern california (bay area)
TDI
2001 NB TDI plus CPO 2013 Passat TDI SEL Prem.
it's a known issue at many VW forums. It only plays mono and is more easily spotted with older tunes that separated the channels (the Beatles did this a lot). The AUX works best for stereo playback.
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
Folx,

it aint gots nuttin to do with Bluetooth - I've been enjoying great BT experience with other cars/adapters, and has everything to do with VW somehow butchering their implementation of BT. Hoping a fix will be released.

For now I am using a $20 Kensington "LiquidAux" BT adapter to feed my Galaxy S2 through Aux input.
 
Last edited:

sensinitas

Member
Joined
Mar 20, 2012
Location
Royal Oak, MI
TDI
MK4 R32 DBP, 04 Denali XL
Got the same issue here. Also - when the phone is hard wired in, and I start the car, after the bluetooth connects, the hard wire connection goes dead. I have to unplug the phone, then plug it back in for it to register. Anyone deal with this as well?
 

r11

Veteran Member
Joined
Mar 6, 2012
Location
NJ
TDI
2012 Passat TDI SE 6MT (BB'd), 2015 Passat TDI SE 6MT
Looks like VW now has a customer case #, where they swapped the RCD with RNS, free of charge and everything. The issue been traced to a defect with newest RCD, late 12 model and on. Look @ vortex for details ... of course they fried his ECU when swapping the radio :(
 
Top