Revised B4 MFA conversion article

TDIL3dad

Veteran Member
Joined
Jan 21, 2012
Location
N. VA
TDI
96 B4, 96 B4V project
* Update --- Derek just notified me that he completed my TDI cluster conversion to MFA functionalities, so I should have it in hand soon.
Also, I already have the oil sensor, and I recently bought the below complete harness and stalk from Germany.

* My question --- are there any issues I should watch for in using US cluster and harness plus stalk from German spec B4?

What other parts or wiring or harnesses are needed?
Is this a plug & play installation??





 
Last edited:

RIP TDI

Top Post Dawg
Joined
Feb 16, 2000
Location
Santa Barbara, CA
TDI
'15 GSW SE 6MT, '01 Golf 5MT, '97 Passat sedan, '96 Passat variant
Looks complete. Sometimes the ambient temp sensor connector in the interior harness is missing. Not a big deal; the wires are there, but no connector for some reason.

Not an MFA issue, but if you have an early '96 with both oil pressure sensors located in the oil filter adapter, you could take this opportunity to update to the later style, where the blue-bodied sensor is installed in the back of the head and the turbo feed line runs from the filter adapter instead of the back of the head.
 

RIP TDI

Top Post Dawg
Joined
Feb 16, 2000
Location
Santa Barbara, CA
TDI
'15 GSW SE 6MT, '01 Golf 5MT, '97 Passat sedan, '96 Passat variant
The stalk switch should be the same as VR6, wiring harness is probably different. You should be using your original harness for this anyway.
 
Last edited:

TDIL3dad

Veteran Member
Joined
Jan 21, 2012
Location
N. VA
TDI
96 B4, 96 B4V project
Today installation was completed on the B4V project of the
MFA cluster with correct cables and sensors and all functions work properly.

Speedeometer at highway speed was within 1-2 miles of GPS.

A public THANK YOU to Derek of Chubbs Auto for his work converting the GLX cluster to TDI configuration, and for Chris Bell who patiently answered my many questions.

Still to do -- sort out non-working cruise control.
 
Last edited:

G60ING

Top Post Dawg
Joined
Aug 5, 2001
Location
Alexandria, VA
TDI
No TDIs Currently, I have an R36 Corrado. I've had an ALH Corrado swap, AHU Corrado swap and 2003 TDI Jetta
You just need to plug the speed sensor, ECU and instrument cluster into the same junction box. They should all have blue single wire plugs with a blue wire with a white stripe iirc.
 

TDIL3dad

Veteran Member
Joined
Jan 21, 2012
Location
N. VA
TDI
96 B4, 96 B4V project
Just completed installation of another Derek modified instrument cluster, this time in my black 96 B4 daily driver.

Driving during daylight hours, one does not notice anything not working.
All the gauges, the speedometer, and the tachometer worked properly.

This evening, drove after dark and noticed that the instrument cluster lights did not work. No lighting for dials, or any of the indicator lights that line the lower edge of the cluster.

Both digital display screens light up and work properly.
The left and right turn indicator lights on the cluster work and flash correctly.

What did I miss?
 
Last edited:

Digital Corpus

Top Post Dawg
Joined
Mar 14, 2008
Location
Ontario, California
TDI
'97 B4 w/ 236K mi body, 46K mi soul
I've not finished going over these PCBs, but the warning and check engine lights are controlled via a two small clusters of resistors. There is a bit of circuitry between them and their pins. There are also 2 ways to access the 8-pin flash chip and one is removing all LEDs and a injection molded plastic lattice to get to it without some passcode. It's possible the LEDs were soldered back onto the PCB backwards and this would present the same way you described.
 

RIP TDI

Top Post Dawg
Joined
Feb 16, 2000
Location
Santa Barbara, CA
TDI
'15 GSW SE 6MT, '01 Golf 5MT, '97 Passat sedan, '96 Passat variant
The 3 2W bayonet bulbs in the top back of the cluster housing produce the frontlighting for the gauges and warning lights.
 

Steve Addy

Top Post Dawg
Joined
Aug 7, 2002
Location
Iowa
TDI
97 Mk3
Is the cruise control stalk different between VR6 and TDI?

This one appears to be TDI specific:

http://www.ebay.com/itm/281647890634?_trksid=p2055119.m1438.l2649&ssPageName=STRK%3AMEBIDX%3AIT
The stalks should not be specific, in fact the turn sig stalk has a 1H part number which suggests it started usage with Mk3 cars in 1993 (in US).

The wiper stalk (w/o MFA) also has a 1H part number but the MFA function stalk has a 53 part number so that probably came from Corrado, most probably from the Corrado VR6.

At any rate these stalks are shared across a lot of different models. Since no 4 cylinder Mk3 cars in the US got MFA you're not going to find a good one there but the VR6 GLX cars did often get MFA (if not standard) so they're available there too.

Steve
 
Last edited:

TDIL3dad

Veteran Member
Joined
Jan 21, 2012
Location
N. VA
TDI
96 B4, 96 B4V project
The 3 2W bayonet bulbs in the top back of the cluster housing produce the frontlighting for the gauges and warning lights.
Replaced the two bulbs and bases with new OEM items from local VW dealer and still no lights.

I suspect the problem is caused by my re-using the the TDI wiring harness.
What wires have to be moved to what connectors to get power to the two bulbs and make the back lighting work?
 

RIP TDI

Top Post Dawg
Joined
Feb 16, 2000
Location
Santa Barbara, CA
TDI
'15 GSW SE 6MT, '01 Golf 5MT, '97 Passat sedan, '96 Passat variant
Replaced the two bulbs and bases with new OEM items from local VW dealer and still no lights.
I suspect the problem is caused by my re-using the the TDI wiring harness.
What wires have to be moved to what connectors to get power to the two bulbs and make the back lighting work?
You replaced 3 bulbs, not 2, right?

The original TDI cluster harness is fully compatible with the GLX cluster. That is not the issue. If your original cluster lighting worked, so will this one. Swap the original back in to check.

Its not that difficult to trace the lighting circuit on the cluster PCB.
 

TDIL3dad

Veteran Member
Joined
Jan 21, 2012
Location
N. VA
TDI
96 B4, 96 B4V project
Yes of course 3 bulbs but still "no go".

I have 12 volts entering the cluster on the terminal 58 circuit, t28 pin 12, when the lights are switched on but no voltage on either of the metal strips that connect to the 3 back lighting bulbs on the outside of the cluster, both show ground. When the high beams are switched on I get 12 volts on BOTH metal strips for the back lighting on the outside of the cluster, but no lights illuminate.

If I manually apply power to EITHER of the metal strips for the back lighting bulbs they do not light but the high beam indicator bulb does light up. This leads me to believe there is a short between the back lighting circuit and the high beam indicator circuit somewhere on the board. Both functions work correctly with another cluster installed.
 

Digital Corpus

Top Post Dawg
Joined
Mar 14, 2008
Location
Ontario, California
TDI
'97 B4 w/ 236K mi body, 46K mi soul
Solder bridge somewhere and man that'll be a fun one to track down. There are 3 places I'd check the front/back of the board. When oriented as if you were driving and it were your cluster, the top right, the resistors & caps on the left 28-pin terminal, and the top left.
 

TDIL3dad

Veteran Member
Joined
Jan 21, 2012
Location
N. VA
TDI
96 B4, 96 B4V project
Ended up sending back to Derek and he corrected and sent back.
Both my daily driver black B4 and blue B4V project have MFA clusters by Derek and both work flawlessly with all functions.

Again, a public THANK YOU to Derek for flawless service.
 

ChubsAuto

Vendor , w/Business number
Joined
Mar 10, 2008
Location
Central Illinois
TDI
2005 TDI Passat, 2003 Jetta Sedan
Adding this to the sticky thread so it wont get lost. Here is a link to a TDI non MFA cluster dump, I have highlighted what I remember and put an explanation with them. In the event I find my info I will update you guys, Hopefully a member will take over where I left off and keep these cars supported for years to come!
https://docs.google.com/document/d/1FNHHTHhgjE9wyXlWVT404OeE39uEqc6c-PqhrxIVOtc/edit?usp=sharing


A list of tools I use for cluster repair as well
https://docs.google.com/document/d/1VnL9hvWN-G6BU-DNYaSuuiwm5K_QJUVc-kq4IMpdF-k/edit?usp=sharing[/QUOTE]
 

lisab4

Veteran Member
Joined
Oct 20, 2013
Location
Belgium
TDI
1996 Passat B4 1.9 TDI
Anyone know what type these (marked 162) are and where I can buy them?
 

Windex

Top Post Dawg
Joined
Apr 1, 2006
Location
Cambridge
TDI
05 B5V 01E FRF
Those are surface mount resistors - newegg or digikey would have them. Why do you think they are faulty?
 
Top