Polar How many people have had trouble with it

dlhovland

Well-known member
Joined
Jun 17, 2012
Location
Yakima
TDI
2015 golf Tdi manual transmission. Wife's car a 2014 toured v6 Tdi
How many people have had trouble with it. Installed mine Saturday was able to program into two screens. Monday drove Car to work. Now every time I hit the OK button when the polar screen is on the display. it makes a phone call and switch to the Phone menu so I cannot access anything anywhere on the polar
 

crashtested

Veteran Member
Joined
Jun 15, 2010
Location
Nelson, BC
TDI
2014 GSW Trendline 6MT, 2004 Jetta GLS 5MT (sold), 2010 GSW Highline 6MT (buy back)
Reflash it. I had this several times and a fresh install seemed to fix it.

It's a pain to re & re the module so when I had mine installed I left the USB data cable plugged in and had it tucked up with a velcro strap so I could just pull it down and plug it into my laptop.
 

dlhovland

Well-known member
Joined
Jun 17, 2012
Location
Yakima
TDI
2015 golf Tdi manual transmission. Wife's car a 2014 toured v6 Tdi
Reflash it. I had this several times and a fresh install seemed to fix it.

It's a pain to re & re the module so when I had mine installed I left the USB data cable plugged in and had it tucked up with a velcro strap so I could just pull it down and plug it into my laptop.
Thanks I will try this weekend. Did know that I could leave the USB cable attached
 

06bluebeetletdi

Veteran Member
Joined
Sep 30, 2012
Location
Middlesex, NC
TDI
'14 Passat TDI SEL and '13 Beetle TDI
My tale of polar fis on my passat:
 

JELLOWSUBMARINE

Veteran Member
Joined
Mar 3, 2014
Location
yes
TDI
2011 Jetta Sportwagen, 6M, red/tan, navi, pano, 83 5m diesel pickup, 82 p/u trailer,.04 5.5 TDI Passat wagon (gone), 80,81,82 diesel p/u (gone), 80,82 sportruck (gone), 59 passthru bus (long gone), 79&87 westy (gone), 57 baja bug (long gone), 73 914
Ive really loved my unit, awsome features... but seems, I like many, have eventually (or right away) had trouble. Mine wouldn't restart after I turned it off to smog test AND installed a Kenwood with idatalink. Do they conflict? Not sure yet. I do miss the polar! soot and regen readouts though

From what I see here on the forum many have some sort of issue after a car trauma. I.E.. Battery, or some sort of electrical?

I still haven't updated to the latest update, but plan to attempt to revive it soon. I have a polar link below you may be interested in
 

dlhovland

Well-known member
Joined
Jun 17, 2012
Location
Yakima
TDI
2015 golf Tdi manual transmission. Wife's car a 2014 toured v6 Tdi
after your experience I think I will remove it and send it it back. Don’t won’t a no stats because of polar unit
 

JELLOWSUBMARINE

Veteran Member
Joined
Mar 3, 2014
Location
yes
TDI
2011 Jetta Sportwagen, 6M, red/tan, navi, pano, 83 5m diesel pickup, 82 p/u trailer,.04 5.5 TDI Passat wagon (gone), 80,81,82 diesel p/u (gone), 80,82 sportruck (gone), 59 passthru bus (long gone), 79&87 westy (gone), 57 baja bug (long gone), 73 914
after your experience I think I will remove it and send it it back. Don’t won’t a no stats because of polar unit
I'm sorry I meant the polar would not open up any preset parameters. It has been flawless up until the above mentioned complication. I absolutely loved the factory like info. display. I like the kenwood/idata add on just as much but it has no info. on the soot and regen.
 

dlhovland

Well-known member
Joined
Jun 17, 2012
Location
Yakima
TDI
2015 golf Tdi manual transmission. Wife's car a 2014 toured v6 Tdi
Thanks I will try updating it first.
 

06bluebeetletdi

Veteran Member
Joined
Sep 30, 2012
Location
Middlesex, NC
TDI
'14 Passat TDI SEL and '13 Beetle TDI
Mine was awesome until it went crazy. Never heard from the company after I returned it to them, it was still under warranty at the time.
 

Wilkins

Veteran Member
Joined
Aug 19, 2005
Location
British Columbia
TDI
05 Jetta Wagon 5sp, 10 Sportwagen 6MT
Before you reflash- because that’s a bit of a pain- try pulling fuse F24, underhood fusebox. That should reboot the Polar. Mine was refusing to restart, but did after I tried removing the fuse.
 

firehawk618

Veteran Member
Joined
Aug 20, 2003
Location
Marysville, WA
TDI
2011 Golf TDI, 2dr, M6, Stock
Got mine from a member on here and so far it's been flawless. * I have removed the factory blue tooth module from my car though and installed an aftermarket head unit.
 

dlhovland

Well-known member
Joined
Jun 17, 2012
Location
Yakima
TDI
2015 golf Tdi manual transmission. Wife's car a 2014 toured v6 Tdi
Contacted auto polar they instructed me to upload late”s up upgrade and then do a factory reset then reinstall unit worked great for about three days. Now all parameters are frozen EGT 32 boost 0 ect I am thinking of just removing it and installing gauges. I left the usb cable plugged into unit. Any thoughts?
 

JD_2012GolfTDI

Well-known member
Joined
May 5, 2019
Location
CA
TDI
2012 Golf Kerma tuned
Minor glitch on mine is that it keeps resetting to read parameters via Diagnostic vs. Engine. I can tell this has happened when the intake air temperature looks incorrect and is stuck on a single temp.
 
Top