PD100 terrible power

golf4tdipd

Active member
Joined
Jan 30, 2020
Location
Slovakia
TDI
golf 4 1.9 TDI ATD
Hey guys, I posted here about that squished hose, so after fixing that and checking some stuff out, the car is still lazy.
It needs much more throttle to go as it used to at low throttle.
Fuel consumption is suprisingly the same despite having to smash the gas more. I cleaned the MAF sensor and it made no difference, neither did unplugging it. Checked all the vacuum lines, the actuator rod moves normally, turbo pushes 16 psi, yet it struggles to go past 120 km/h. Im clueless as to what it could be.
 

golf4tdipd

Active member
Joined
Jan 30, 2020
Location
Slovakia
TDI
golf 4 1.9 TDI ATD
Thought that too, changed the fuel filter, made a tiiiny differemce, but that was probably because it was about time to change it anyways.
 

BobnOH

not-a-mechanic
Joined
May 29, 2004
Location
central Ohio
TDI
New Beetle 2003 manual
Weak in-tank or tandem pump? Though it's usually some wire or sensor. Check if any codes have been stored (other than MAF).
 

golf4tdipd

Active member
Joined
Jan 30, 2020
Location
Slovakia
TDI
golf 4 1.9 TDI ATD
Alrighty, the only thing I havent done is hooked it up to a scantool, will do and tell you guys.
 

Curious Chris

Top Post Dawg
Joined
Jun 11, 2001
Location
Pineview GA
TDI
Jetta Wagon 2003 RIP Rockford IL
I had a no CEL MAF failure on my 2002 Golf TDI and it would not go past 60 mph. Cleaning does not always fix it and X2 on getting VCDS as it will tell you what the MAF is doing and the MAP too.
 

golf4tdipd

Active member
Joined
Jan 30, 2020
Location
Slovakia
TDI
golf 4 1.9 TDI ATD
Unplugging it made barely any difference, but I was wondering if the intercooler could cause any issues if its bent like in the picture I sent.
 

JB05

Top Post Dawg
Joined
Oct 20, 2005
Location
Il.USA
TDI
Golf,2005,anthracite blue
Looks like the IC could be leaking. Worth checking into.
How did it get banged up like that?
 

golf4tdipd

Active member
Joined
Jan 30, 2020
Location
Slovakia
TDI
golf 4 1.9 TDI ATD
Well, I plugged it into a diagnostics tool, only showed the MAF, but that was because I was driving with it unplugged. After resetting the codes nothing showed up. Since unplugging the MAF did nothing, is it dead?
 

turbovan+tdi

Top Post Dawg
Joined
Mar 23, 2014
Location
Abbotsford, BC.
TDI
2003 TDI 2.0L ALH, auto, silver wagon, lowered, Colt stage 2 cam, ported head,205 injectors, 1756 turbo, Malone 2.0, 3" exhaust, 18" BBS RC GLI rims. 2004 blue GSW TDI, 5 speed, lowered, GLI BBS wheels painted black, Malone stage 2, Aerotur
If the IC has a hole, it will cause it to be sluggish as the MAF readings are off.

Get into your data, put up boos requested vs boost actual and N75 %.

What is your torsion value?

How many miles? Its possible you have a cam going flat as well, or if it has a cat, could be plugged up.
 
Top