P2002 code while driving last night

ranger pete

Veteran Member
Joined
Jul 29, 2011
Location
connecticut
TDI
2011 JSW 6MT
Near the end of about a 550 mile day I got a CEL maybe about 10 miles after filling up the tank.

Took it to AZ this morning and pulled the codes. P2002.

Scanning it reset the CEL. Haven't driven a lot, maybe 25 miles since with no recurrence.

It is an '11 JSW 6MT. 154K miles. VW replaced the intake last fall at about 120K under warranty for the throttle plate sensor failure code.

Runs great. typically get 43-45 mpg, mostly highway.

It is still bone stock, but I have considered changing that as I do believe I am out of warranty, but after reading a few posts here, I am wondering if that is the case.

Any advice appreciated, including recommendations of local mechanics. I brought it to 413 Auto shortly after buying it just to do an oil change and give it a one over. He seemed pretty adamant about keeping it all stock, even after the warranty runs out. I see People's Auto in Somers listed also. Only about 15 minutes away.

Anyone have any experience with them and how friendly they are to mods?

No need for more power, really. I'd just use it and break stuff. Better mpg/durability is more my goal. I love this thing and would like to get another 150K+ out of it. Best car I have ever owned. 500 mile days in it are a breeze.
 

ranger pete

Veteran Member
Joined
Jul 29, 2011
Location
connecticut
TDI
2011 JSW 6MT
Looks like I made a redundant thread. The other one already has a reply, so can a mod please flush this one or tell me how I can? I see how to edit, but not delete.
 
Top