P0380 Glow plug Heater malfunction

Mk3_Moe

Active member
Joined
Feb 19, 2021
Location
Sacramento
TDI
1998 Mk3 TDI AHU
Didn’t know how to start a thread but I found out now lol. So basically I bought 98’ Jetta Tdi Ahu with a p0380 code. The previous owner stated that he had problem with a glow plug going out so he replaced the plugs, wiring harness, fuses and relays. He told me everything was running good after but the code was still there. He said it’s because the timing belt has to be replaced and fuel injection pump has to be retimed, and he said that might be the cause. I’m not sure so I wanted to see if that could be the case
 
Last edited:

Mongler98

Top Post Dawg
Joined
Mar 23, 2011
Location
Northern MD (HAGERBUSH)
TDI
98 Jetta TDI AHU 1.9L (944 TDI swap in progress)
Timing and timing belt has nothing to do with the ECU with regards to glow plugs working or not.
Get the multimeter out and test everything.
My guess is the PO didnt use good stuff and the parts used are going or are bad or damaged.
If anything, do the timkng belt properly before you do anything. These cars are so picky with old or bad parts for timing.
 

Mk3_Moe

Active member
Joined
Feb 19, 2021
Location
Sacramento
TDI
1998 Mk3 TDI AHU
Timing and timing belt has nothing to do with the ECU with regards to glow plugs working or not.
Get the multimeter out and test everything.
My guess is the PO didnt use good stuff and the parts used are going or are bad or damaged.
If anything, do the timkng belt properly before you do anything. These cars are so picky with old or bad parts for timing.
Yeah I figured, I took it to one of my vw techs and he said it has nothing to do with fuel injection pump and timing, he found that there was faulty wiring harness. PO said he made the wiring harness out of some marine grade material lol. My guess was that didn’t go well. I’ll let you know how it goes. Thank you!
 
Top