IQ deviation issue

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Remanded pd150 injectors are acting weird. The IQ deviation moves all over the place.

When I first start they are balanced within +/- ,75

But as I start to drive injector 3 wants to nearly exceed 3

other times while driving steadily things are all within +/- .75 BUT if I shift into neutral for any reason they start to get weird snd #3 climbs past +2 every time…


The IQ was dead on before swapping the nozzles.
Im gonna check the lash tomorrow. Other than than that IDK what else it could be. Car is running decent. Just finishing up some major changes and trying to get it sorted so I can go see my dad for the first time since before Covid.
 

BustedBolts

Well-known member
Joined
May 23, 2018
Location
PA USA
TDI
2001 and 2002 Golf's
What are the values in groups 18 and 23? Where the bip maps, fuel temp corrections, soi and doi maps in the tune corrected for the pd150 injectors?
 

Mongler98

Top Post Dawg
Joined
Mar 23, 2011
Location
COLORADO (SE of Denver)
TDI
98 Jetta TDI AHU 1.9L (944 TDI swap in progress) I moved so now i got nothing but an AHU in a garage on a pallet.
Did you DIY the nozzles or did you have somone donut or a hot swap... who did you get them from or have do it?
 

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
Remanded pd150 injectors are acting weird. The IQ deviation moves all over the place.

When I first start they are balanced within +/- ,75

But as I start to drive injector 3 wants to nearly exceed 3

other times while driving steadily things are all within +/- .75 BUT if I shift into neutral for any reason they start to get weird snd #3 climbs past +2 every time…


The IQ was dead on before swapping the nozzles.
Im gonna check the lash tomorrow. Other than than that IDK what else it could be. Car is running decent. Just finishing up some major changes and trying to get it sorted so I can go see my dad for the first time since before Covid.
IQ of 2.99 is a total misfire... Where did you get the injectors/ who swapped the nozzles?
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Logs about to be made. Warm up was good just like before.
I installed them. Lash is set correctly. I do know they are finicky to setup snd am considering doing the lash again. I might take and adjust injector 3 a little cuz it seems to be the problem , but I will want to grab a new injector holddown bolts first.

As for the suppliers I got them remanded from Germany. Lol but the supplier has 167k sales and a full 5 star review. I’ll share the links if you like

My tuner is In the UK. My turbo also came from the UK. The car is a Pd100 BEW.
I labeled the pop testing results that were included so I know which went where. I suppose if I do adjust 3 I may just swap
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
So my logs disappears while I’m looking at them at Starbucks before I uploaded them to drive. I can’t find them anywhere/

after driving around watching VCDS is the issue is related to idle for sure…

I’m gonna swap injector 3 snd 2 to see what happens.

here is idle
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
I did get a video of me experimenting on my idol theory.https://youtu.be/NTVcOnccYyw

I will do some more logs of channe 23 and 18 with 04 To show engine speed too.
 

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
So my logs disappears while I’m looking at them at Starbucks before I uploaded them to drive. I can’t find them anywhere/

after driving around watching VCDS is the issue is related to idle for sure…

I’m gonna swap injector 3 snd 2 to see what happens.

here is idle
That's an almost complete misfire. Swap injectors from one to the other and see if it's following that injector.
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
In the meantime what can cause the IQ deviation to be so wildly off at idle but when cursing it’s spot on?

besides bad hardware ? Any specific area or a tune to look ? I have some software and everyone can use edumasterhp.com
 

tdi_my live

Veteran Member
Joined
Jul 24, 2011
Location
Germany
TDI
Skoda Fabia
Logs about to be made. Warm up was good just like before.
I installed them. Lash is set correctly. I do know they are finicky to setup snd am considering doing the lash again. I might take and adjust injector 3 a little cuz it seems to be the problem , but I will want to grab a new injector holddown bolts first.

As for the suppliers I got them remanded from Germany. Lol but the supplier has 167k sales and a full 5 star review. I’ll share the links if you like

My tuner is In the UK. My turbo also came from the UK. The car is a Pd100 BEW.
I labeled the pop testing results that were included so I know which went where. I suppose if I do adjust 3 I may just swap
You use an open Flasher or a seller thing with cripted Files?
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
I’m using MPPS. A nice guy named Stewart on an ECU tuning group decrypted the file I pulled off my ecu with MPPS.

I’ll gladly share the OG file I pulled.
As for the tune I’m running it came with a copywritten warning.


I bought the car about 18 months ago.
it had a tune. I sent Malone some messages and logs inquiring about the tune. If he could identify it as being his tune. I never did send him the actual .bin file. he checked the VIN nothing came up. Charlie never responded to the same request. Of course this was all before I decided I needed to make some hardware changes.
 
Last edited:

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
In the meantime what can cause the IQ deviation to be so wildly off at idle but when cursing it’s spot on?

besides bad hardware ? Any specific area or a tune to look ? I have some software and everyone can use edumasterhp.com
If the secondary injection pressures aren't set correctly it could do that.
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
At a glance at the logs it would would appear that it's a mechanical injector issue. The bip maps seem to be corrected in the tune.
I readjusted the lash just in case.


I am gonna open it up and give #3 a slight rotation and see what happens.

if that don’t change I’ll seap # 2 and #3 and see what happens.

but first, I have a slight exhaust leak the stupid shop can’t seem to fix and I’m gonna build a boost leak tester, cuz I think I here a leak.
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
If the secondary injection pressures aren't set correctly it could do that.
could a boost leak cause the funny IQ deviation ?
Or Seems unlikely to me, but What about a slight exhaust leak at the Pyrometer?

Haha collage , I don’t fully understand combustion engines, but I could tell you if a Chemical equation was combustion or not based on the mathematics LOL
 
Last edited:

powermandan

Active member
Joined
Apr 5, 2021
Location
Worcester UK
TDI
ABL, AHU, AFN
How is the ECU measuring the deviation?

Looking at photos of the PD Injector loom, it appears they are only 2 wire. So no metering.

My suspicion is that it is measuring the time it takes one revolution of the crankshaft very accurately and correlating that with which injector just fired.

Presumable increasing voltage to the injectors that are not producing quite as much power to level them out.

If that is the case, then it won't be anything to do with boost or exhaust or anything shared between cylinders.

More likely to be injector/Cam lobe/compression.

I would swap the injector as you have said, if problem doesnt move, then cam or compression.
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
first, is the car really safe to drive in the meantime like this? I’d like to do 1000 miles soon snd see my dad.

Second, It must be the injectors installed slightly croooked or unbalanced injector. Cuz I did not have this issue in the logs before switching injectors; they are the only hardware change. Well that and a 4 bar map. That and a tune. One of this three things is causing it.

Thanks for the reminder; I still need a fitting to test the compression, I have a snap on Diesel tester. It doubt low or unbalanced compression is causing this issue cus just before i swapped the sticks this was not happening.


Your correct they are two wires, and I’ve been noticing they don’t move much sometiems when driving but others they move a lot snd that makes me think maybe the wiring loom is bad. I forgot to check if there is still a CEL for that in the tune when I reset the last

Finally; the cam is new and I have logs before the old injectors without this issue.

Thanks everyone for all the support !
 
Last edited:

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
first, is the car really safe to drive in the meantime like this? I’d like to do 1000 miles soon snd see my dad.

Second, It must be the injectors installed slightly croooked or unbalanced injector. Cuz I did not have this issue in the logs before switching injectors; they are the only hardware change. Well that and a 4 bar map. That and a tune. One of this three things is causing it.

Thanks for the reminder; I still need a fitting to test the compression, I have a snap on Diesel tester. It doubt low or unbalanced compression is causing this issue cus just before i swapped the sticks this was not happening.


Your correct they are two wires, and I’ve been noticing they don’t move much sometiems when driving but others they move a lot snd that makes me think maybe the wiring loom is bad. I forgot to check if there is still a CEL for that in the tune when I reset the last

Finally; the cam is new and I have logs before the old injectors without this issue.

Thanks everyone for all the support !
I highly suspect the injectors in this one, likely improperly calibrated.. You'll be able to tell if the issue follows the injector.
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
I agree it is likely injectors.
lookint back at these print outs #3 seems funny.



I’m Just covering all bases first. I did make a pressure tester just now and my vnt 17 adapter is leaking, it won’t even hold 5 psi, I have a job to do near tacoma screw tomorrow so im gonna pick up a 3.5 x 45mm o-ring and see what happens. Then Ill swap the nozzles.
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
I highly suspect the injectors in this one, likely improperly calibrated.. You'll be able to tell if the issue follows the injector.
Ok, so your correct.

injector #3 is the problem…how dangerous is this condition in the? Will I damage the engine driving ?
 
Last edited:

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
Ok, so your correct.

injector #3 is the problem…how dangerous is this condition in the? Will I damage the engine driving ?
I would definitely not run it. A failed injector can dump too much fuel in and overheat the engine and melt pistons. Not worth the risks in my book
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
I appreciate the help. Thank you.

I won’t be driving it until I get a new injector.

Ironically, after driving yesterday;

I’m now having the infamous break light switch issue. Oh, yes, it is complete with with the blinking glow plug light…HAHAH stupid VW.

I think I’ll grab a injector wiring harness too, I got away with it once… I think it may be possibly for it to cause the blinking glow plug even, tho I have a fault code doe the break light switch.
 
Top