Intermittent Check engine light

Rapidrob

Veteran Member
Joined
Jun 20, 2004
Location
Edgewood,New Mexico
TDI
96' Passat Wagon
'96 Passat TDI wagon.
For the last month or so I've been getting an intermittent Check Engine light when the engine is cold and the engine is at a lower than highway speed.

After ten minutes or so, the light gets very dim,flickers and then goes out and stays out.
I do not own a VAGCOM.
All of the vacuum lines are new. The engine NEVER goes into limp mode.
The vacuum pump is new.
I am not sure what all will turn on the CEL?
240,000 miles on wagon.
 

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
Well, you need to either get vag-com or take it to someone who does, since there are a gazillion things that could turn the check engine light on. Any error code in the computer could turn it on.

Sent from my S60 using Tapatalk
 

Rapidrob

Veteran Member
Joined
Jun 20, 2004
Location
Edgewood,New Mexico
TDI
96' Passat Wagon
I borrowed a VAG COM from a friend who owns an Audi. The error code said EGR valve, The sensor for the EGR valve is remote.
I removed the air box for the filter and the two air plenums and I found two "mouse chewed" wires in the bundle at the lower rear of the air box. A Yellow and Black wire and a White wire going to the quick disconnect plug to the remote EGR valve sensor.
I was able to solder the wires back together. I will do a test run later as I ordered a new air filter while doing the repair.
 
Last edited:

Mozambiquer

Vendor , w/Business number
Joined
Mar 21, 2015
Location
Versailles Missouri
TDI
1998 VW Jetta TDI. 1982 VW Rabbit pickup, 2001 VW Jetta TDI, 2005 VW Passat wagon TDI X3, 2001 VW golf TDI, 1980 VW rabbit pickup,
I borrowed a VAG COM from a friend who owns an Audi. The error code said EGR valve, The sensor for the EGR valve is remote.
I removed the air box for the filter and the two air plenums and I found two "mouse chewed" wires in the bundle at the lower rear of the air box. A Yellow and Black wire and a White wire going to the quick disconnect plug to the remote EGR valve sensor.
I was able to solder the wires back together. I will do a test run later as I ordered a new air filter while doing the repair.
There you go! Good job, welcome to the world of diagnostics!

Sent from my S60 using Tapatalk
 

Steve Addy

Top Post Dawg
Joined
Aug 7, 2002
Location
Iowa
TDI
97 Mk3
Awesome job, nothing better than finding the problem and doing it quickly!

Steve
 
Top