engine oil warning light

m1ketdi

Veteran Member
Joined
May 18, 2009
Location
Leam
TDI
Leon BKD
Well today i got onto sorting the problem of my oil leak on my mk2 ibiza 1.9tdi with AHU engine. The problem was the low pressure switch for the oil pressure warning light had deteriorated with time And was letting oil spurt out past it. So i thought fine off to euro car parts and get a new one. Got a new one and fitted it but still getting the same flashing engine light and buzzer if i keep the car above 2000rpm for any period of time. So after looking at the wiring diagrams i can see that if you disconnect the switches and don't let the wires touch earth the light shouldn't go off so i try this still no joy light and buzzer still come on. So then i connected up vag-com and checked for fault codes of which i found none but iv'e only got the shareware version and it's not getting all the blocks when i scan so that might be my problem but it definately scans the engine and immobiliser blocks. So after this i thought i may as well check if the oil pressure is acutally there which i hoped it would be as the engine hadn't lost much oil when the pressure switch had broken the first time. Put a gauge on and theres plenty of pressure at all revs. So now im wondering is anything else connected to the engine oil warning light? There is one random wire not connected at the front of the engine which comes out of the loom in the same place as the low pressure oil switch but that looks like it's been off for ages and the car was fine above 2000rpm until the oil started leaing past the switch. This has got me really confused now. Any help is much appreciated.
 

m1ketdi

Veteran Member
Joined
May 18, 2009
Location
Leam
TDI
Leon BKD
Just to add checked the wires and they aren't shorting to earth. Can anyone tell me whether the high pressure sensor on the side of the block should be earthing out when the engine isn't on? and pictures of the wire which i don't know where it connects too.

 
Last edited:

RIP TDI

Top Post Dawg
Joined
Feb 16, 2000
Location
Santa Barbara, CA
TDI
'15 GSW SE 6MT, '01 Golf GLS 5MT, '96 Passat variant
The 1.0 bar switch is NO, so is not earthed with zero pressure. The unconnected wire is for models equpped with an MFA which yours is not. It attaches to an oil temp sensor on said models.
 

m1ketdi

Veteran Member
Joined
May 18, 2009
Location
Leam
TDI
Leon BKD
Cheers mate, i'd figured i'd got a problem when both my switches where running to earth at the same time. What i'd done was bought a .3 bar switch and put it in the 1 bar hole which ends up with an annoying bleeper going off at you whenever you give it some welly. Thanks for the info about the spare wire. Useful to know if i ever wanted to install an MFA.
 
Top