Engine Hiccup

PineRidgeTDI

New member
Joined
Sep 10, 2022
Location
Montana
TDI
2015 VW Golf Sportwagen 2.0 TDI s
When I am driving my 2015 Golf Sportwagen TDI s I will get a drop off in engine RPMs. I would describe it as a hiccup while driving as the RPMs fall off and then come back up. It seams to happen while driving at highway speeds mostly. It has happened a few times while driving in town. Since it seams to happen most often at highway speeds I can't determine if is happening while the car is doing a regen cycle or not. I recently changed the oil, fuel filter, and air filter. It was in the VW dealership for the 150k service and they did not have anything to report.

The car has 156k, and is not showing any CEL.

Any help on the issue would be much appreciated.
 

pedroYUL

Veteran Member
Joined
Sep 8, 2011
Location
MI, USA
TDI
2015 Passat CVCA; 2015 GSW CRUA; 2012 wagon CJAA; 2004 wagon BEW
Read here:
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
Wish it was easier to load a video here like on other sites. I just ordered a crank position sensor for mine- part # 04L-906-433-B . Got it for $58.85+ shipping from Ancira VW in Texas(VW Direct Auto Parts.com). IDParts didn't carry it. Maybe they should....
 

PineRidgeTDI

New member
Joined
Sep 10, 2022
Location
Montana
TDI
2015 VW Golf Sportwagen 2.0 TDI s
Thanks for the input I ordered the part, will put it in when it gets here, I live in Montana.
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
I just got the tracking # for my CPS. I'm gonna wait to put it in. When I took skidplate off, I wiggled the wire for CPS that goes by the oil filter housing. It didn't look or seem to be pinched, but haven't had a hiccup issue since🙄
 

Mike_04GolfTDI

Top Post Dawg
Joined
Nov 19, 2003
Location
Richmond, BC, Canada
TDI
Mine: 2019 Golf R DSG, Wife's: 2015 Golf Comfortline TDI
Another one… It’s like the 2015 crank position sensors are all failing now.

That link posted by pedroYUL was from when my wife’s car developed this problem last year. VW dealer was not capable of fixing it even after being told what the problem was.

If you have VCDS you can test the sensor, but you’ve already ordered one so you may as well just try it, and most likely that will fix the problem.
 

740GLE

Top Post Dawg
Joined
Aug 19, 2009
Location
NH
TDI
2015 Passat SEL, 2017 Alltrack SE; BB 2010 Sedan Man; 2012 Passat,
any soft codes stored for these failing CPS?

or is it primarily "driving feel" as a precursor to fully failed units?
 

pedroYUL

Veteran Member
Joined
Sep 8, 2011
Location
MI, USA
TDI
2015 Passat CVCA; 2015 GSW CRUA; 2012 wagon CJAA; 2004 wagon BEW
IMO Mike had a failed CPS and he had no codes at all, nothing stored
 

740GLE

Top Post Dawg
Joined
Aug 19, 2009
Location
NH
TDI
2015 Passat SEL, 2017 Alltrack SE; BB 2010 Sedan Man; 2012 Passat,
yippy another thing to keep an eye out for.
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
I had the engine hiccup today for first time since I wiggled wire a few weeks ago. The only code stored in VCDS was due to the stalling with flashing glow plug light, a P02149 fault. CEL did go out by itself, but I made sure not to clear it.
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
Today was the worst day of the stuttering. Going 30mph it stalled. Coasted to side of road, shut ignition off, started right back up. Still did the stuttering for a few minutes, eventually cleared up. Hour or so later on way home from a Subaru dealer, started the stuttering again. This time the ESC light came(said something in the information center), then the TPMS light came on, then a flashing glow plug light. Didn't stall or trip CEL this time. But car did seen like it was in limp mode, didn't accelerate properly. Got it home, shut it off. Started it back up, all lights went out. Decided to drive it to dealer. Drove normal like nothing was wrong for the 40 mile drive. I showed the service manager video I took of the flashing glow plug light, ESC and TPMS light on, and the lack of power. I also told him about the P02149 code that is stored... we'll see if they find anything. I'll post updates when I get them. Saw a 6 spd 2023 Crosstrek I liked at the Subaru dealer when I made appointment for service for the wife's Crosstrek...also just read this is last year for manuals in the Crosstrek..
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
Update- dealer pulled some codes, and they ordered a crankshaft position sensor. Advisor also said it’s covered under Dieselgate warranty. They just got part in(overnight shipping)said should get to it tomorrow . Fingers crossed
 

super1

Veteran Member
Joined
Apr 19, 2010
Location
NY
TDI
none
I just got the tracking # for my CPS. I'm gonna wait to put it in. When I took skidplate off, I wiggled the wire for CPS that goes by the oil filter housing. It didn't look or seem to be pinched, but haven't had a hiccup issue since🙄
I thought you ordered your crank position sensor in February did you not get it then?
let us know what happens with the one from the dealership
 

740GLE

Top Post Dawg
Joined
Aug 19, 2009
Location
NH
TDI
2015 Passat SEL, 2017 Alltrack SE; BB 2010 Sedan Man; 2012 Passat,
That was prob his fall back if the dealer wasn't going to do it under warranty.
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
Yeah, I ordered and got it last month. I was gonna do it once it got warmer, but the episode on the 4th had me take it to dealer, only code stored was P02149. They were able to diagnose/test sensor and their test plan said to replace the crank sensor as a test. Picked it up today, no charge thanks to Dieselgate warranty. I'll keep ya posted if it comes back or not....
 

super1

Veteran Member
Joined
Apr 19, 2010
Location
NY
TDI
none
Yeah, I ordered and got it last month. I was gonna do it once it got warmer, but the episode on the 4th had me take it to dealer, only code stored was P02149. They were able to diagnose/test sensor and their test plan said to replace the crank sensor as a test. Picked it up today, no charge thanks to Dieselgate warranty. I'll keep ya posted if it comes back or not....
That’s the problem with that sensor a lot of times it doesn’t throw a code
Yes, let us know how it goes
 

Mike_04GolfTDI

Top Post Dawg
Joined
Nov 19, 2003
Location
Richmond, BC, Canada
TDI
Mine: 2019 Golf R DSG, Wife's: 2015 Golf Comfortline TDI
Yeah, I ordered and got it last month. I was gonna do it once it got warmer, but the episode on the 4th had me take it to dealer, only code stored was P02149. They were able to diagnose/test sensor and their test plan said to replace the crank sensor as a test. Picked it up today, no charge thanks to Dieselgate warranty. I'll keep ya posted if it comes back or not....
Maybe they went and read my thread on the subject to figure out how to test it. LoL.
My dealer had no clue.
 

pedroYUL

Veteran Member
Joined
Sep 8, 2011
Location
MI, USA
TDI
2015 Passat CVCA; 2015 GSW CRUA; 2012 wagon CJAA; 2004 wagon BEW
whats the p/n of the crank sensor?
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
i dont need it yet I was just trying to be a little proactive
I got lucky and car ran like sh*t for quite a few miles including limp mode, didn't throw a check engine light the last episode like it did previously. But luckily Basil VW in Lockport was able to diagnose/test/pull codes on their computer. I've heard some other dealers weren't able to do that. Also depends if you still have Dieselgate warranty left. Not sure how Ide or Bob Johnson(formerly Dorschel) service departments are-I used to use Dorschel, but I heard when Bob Johnson took over that there was an exodus of mechanics there...
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
Welp, we may be back to square one :mad: :mad: :mad: . Past couple weeks I've been having occasional long first starts(in morning, or leaving work). It cranks for a good 3-4 seconds and not the instantaneous starting I'm accustomed to. Then tonight about 2 miles from work on way home(in a 30mph zone). I felt a slight hiccup, then glow plug light only started flashing- like limp mode, no acceleration for about a tenth of a mile then it died. Coasted to side of road, shut off ignition, fired back up like nothing happened. Fine all the way home. I actually already have dealer visit scheduled for tomorrow morning to check over car before I the Allstate extended warranty I bought when I purchased car runs out next month.... will keep updated....
 

super1

Veteran Member
Joined
Apr 19, 2010
Location
NY
TDI
none
Welp, we may be back to square one :mad: :mad: :mad: . Past couple weeks I've been having occasional long first starts(in morning, or leaving work). It cranks for a good 3-4 seconds and not the instantaneous starting I'm accustomed to. Then tonight about 2 miles from work on way home(in a 30mph zone). I felt a slight hiccup, then glow plug light only started flashing- like limp mode, no acceleration for about a tenth of a mile then it died. Coasted to side of road, shut off ignition, fired back up like nothing happened. Fine all the way home. I actually already have dealer visit scheduled for tomorrow morning to check over car before I the Allstate extended warranty I bought when I purchased car runs out next month.... will keep updated....
I thought that Cranks Sensor would have fix it :(
Did you happen to scan for codes now?
 

tdidieselbobny

Top Post Dawg
Joined
Apr 4, 2005
Location
Stafford,NY (WNY)
TDI
'03 Galactic Blue Jetta TDI, '15 Silk Blue Golf Sportwagen TDI
I thought that Cranks Sensor would have fix it :(
Did you happen to scan for codes now?
Didn't scan for codes. Dealer did test injectors and said the #2 wasn't working correctly(can't remember exactly what advisor said, and didn't get any paperwork as it's still an open repair) -they ordered one, and taking it back next Thursday morning for install if they get it. Covered by Dieselgate warranty, and don't have to pay the $179.95 diagnostic charge. Once they install it he said they will test all the injectors again.
 

super1

Veteran Member
Joined
Apr 19, 2010
Location
NY
TDI
none
Didn't scan for codes. Dealer did test injectors and said the #2 wasn't working correctly(can't remember exactly what advisor said, and didn't get any paperwork as it's still an open repair) -they ordered one, and taking it back next Thursday morning for install if they get it. Covered by Dieselgate warranty, and don't have to pay the $179.95 diagnostic charge. Once they install it he said they will test all the injectors again.
Ok sounds good
Please keep us up to date on this
 
Top