CR TDI throws P0238+P0113+P1592

Joined
May 9, 2021
Location
Norway
TDI
2.0TDI Golf
I bought a super cheap 2010 passat B6 with a CEL+flashing glowplug light, never thought I would but it was too cheap to let it go.
It throws the following:

P0113 Intake air temp circiut high input
P0238 Turbocharger boost sensor A Circuit high
P1592 Altitude sensor/boost pressure sensor Implausible ratio
These three fault codes appear equally but at totally random times, normally while engine braking/slowing down but usually not during high engine load.

Previous owner tells me it could work just fine after deleting the fault codes for two weeks or two minutes. To me it sounds like a wiring issue to the boost pressure sensor, is that a common fault on these motors? He also took the car to a shop where they replaced EGR+ASV, checked the turbo, turbo+actuator was good, and told him this issue most likely is a wiring issue and not a bad sensor.

Its a high milage car so I guess wiring issues could/would be the issue here.
Engine is a 2L CR CBDC..
 

Kelv.rees86

New member
Joined
Nov 25, 2021
Location
Swansea
TDI
Skoda superb CR TDI
Hi mate, out of curiosity, did you ever get this problem sorted? I have a 300k mile taxi with the exact same problem and fault codes
 
Joined
May 9, 2021
Location
Norway
TDI
2.0TDI Golf
Yes. It was the wiring harness to the MAF sensor (not MAP sensor as many mixes these). It measures boost and boost air temp. I changed the sensor without any luck then traced the harness that goes to it. Found a broken wire probably due to vibrations over time and too short wires from factory. Soldered the wire and all good! Funny thing is it would run perfect after deleting the codes if I didnt coast on the gears/engine braking. Probably because when the I was coasting, the engine was moving just enough on the engine mounts to take the two broken wire stumps away from each other if that makes sense.
 
Top