Coding procedure for CCM Window Modification

graeme86

Veteran Member
Joined
Jan 14, 2005
Location
Brisbane, Australia
TDI
Not yet - fuel is too cheap! - 3.2 VR6 R32
Attn Computer gurus (you know who you are;) ), I am requesting some help getting this program to run.

I can get the VDS Pro main screen to come up just using 16-bit DOS program from XP.

I bought one of these cables which is known to work for others:

http://cgi.ebay.com/ebaymotors/Serial-KKL-Vag-Com-Cable-Interface-VW-Audi-Scanner-VAG_W0QQitemZ280032725633

I just keep getting the "Wait" message saying "No answer from control unit" The cable light blinks while attempting to connect.

I used compu-85's config file with program.

In the VDS Pro program are the following settings:

Under Configuration/Connect I have:
COM Port 1 ; Baud rate Fixed at 9600
Control Unit <Start> 01 hex
Connection attempts 3

Under Configuration/Protocol I have (listed down):
2500
40
1
1
150
60
30
600
1100
800

I assume these figures come from the config file and should be correct.
COM port 1 is being accessed okay by the program it appears.

In the actual computer hardware settings, do I need to change anything to get this working? This is my home computer with a proper serial port (Intel Celeron 2.4 GHz processor)

Under device manager:
Com Port Settings:
Bits per sec 9600
Data bits: 8
Parity: None
Stop bits 1
Flow Control: None
Under advanced settings:
Use FIFO buffers is UNCHECKED (not active)
Com Port : COM1


I have also got this same setup running on a laptop thru a Quatech SSP-100 PCMCIA RS-232 card. Same scenario - "No answer from control unit"
Laptop recognises card as COM1 okay! (This is one of the VAGCOM recommended serial adapters by the way)

Under device manager:
Com Port Settings:
Bits per sec 9600
Data bits: 8
Parity: None
Stop bits 1
Flow Control: None
Under advanced settings:
The default setting appears to be:
FIFO Compatability Mode - Use 16750 Compatable UART
and the Receive and Transit buffer sliders are on highest settings.
(This is different to home computer settings as above)
Com Port: COM1

The card also shows up on Hardware menu as a "Multiport serial adapter" separately:
Under its advanced settings you can change the clock rates etc ("Data Rate Multiplier"

I have tried "Auto" which sets maximum Baud of 921600
and also tried " X1" which sets it to 115200
(Laptop has Intel Celeron M Processor 1.60 GHz)
Am I on the right track with this stuff? :confused:
The program just won't connect, with either the laptop or home computer.:mad: That home one was a real downer as I had just dismantled and carried everything down two flights of stairs to try it!:rolleyes:

If someone could confirm their working configuration settings, I would be most appreciative. People have mentioned "timing issues" previously

OR...it just doesn't work in XP in 16-bit mode at all?:confused:

OR...the cable doesn't work in this case (..next step...MONO-COM)

Thanks guys!:)

Edited to show ebay seller as link to cable is now dead: chiltonsondemand
 
Last edited:

madelgado

Veteran Member
Joined
Dec 7, 2006
Location
Spain
TDI
Passat 3BG 2001
Hello, have you tried vag-com 3.11 with the same cable? there is a demo-version that you can try to test the wire. That is exactly the same problem I had once when my cable broke (in the end it was one wire of the db9 connector)
 

mtltdi

Veteran Member
Joined
Apr 1, 2003
Location
Canada
TDI
2003 Golf GLS, Indigo Blue
Press escape when it says wait...this will bring you to the full list of control units. Or change the default control unit to be the CCM - "46" when you startup the program. Key in the ignition switched to on position also.
 

TeleDawg

Veteran Member
Joined
Apr 19, 2004
Location
LosAnchoros, Alaska
TDI
Golf GLS, 2004, Reflex Silver
can get the VDS Pro main screen to come up just using 16-bit DOS program from XP.

I've never been able to get a connection from a command shell in Windows. WOW somehow messes with the intricate serial port timing that VDS Pro needs.

You will need to make a boot disk (Win95 or Win98) to get this to work reliably. There is plenty of info out there already about this subject.

T.D.
 

compu_85

Gadget Guy
Joined
Sep 29, 2003
Location
La Conner, WA
TDI
... None :S
1: If the cable only works with vesion 311 of vag-com, it won't work with VDS-PRO. I have 2 cables, one that only works with 311, and one that works with 409. The 'cheaper' cable won't work with vds, but the one that works with 409 (it's actually a ross-tech Uni-Comm) works great.

2. You really must run this program in dos. I have tried running it in XP, and it simply doesn't work.

-Jason
 

graeme86

Veteran Member
Joined
Jan 14, 2005
Location
Brisbane, Australia
TDI
Not yet - fuel is too cheap! - 3.2 VR6 R32
Its so tantalisingly almost working.:(

I wasn't sure if anyone had actually got it to work in XP - DOS

The screen comes up with all the control units listed - just can't access any.

I don't have Windows 98 etc so I will make a DOS boot disk and try that.

It would have been nice to flick back to XP so I could read the instructions and thread posts etc.

I thought maybe that "FIFO buffer" set up might be the problem in the config settings.

Thanks for the feedback.:)
 

Nate_Grauvogel

Veteran Member
Joined
Feb 10, 2005
Location
CO
TDI
'15 T-Reg Exec
graeme86 said:
I don't have Windows 98 etc so I will make a DOS boot disk and try that.
All the mentions of Win98 et al. just refer to the version of Windows used to make the DOS boot disk. I've tried several downloaded boot disk images from and ones I've made myself using XP - all work equally well. ;)

Yes, it would be very nice to be able to run the program in a windows shell, but no one's done it yet, AFAIK. :rolleyes:
 

graeme86

Veteran Member
Joined
Jan 14, 2005
Location
Brisbane, Australia
TDI
Not yet - fuel is too cheap! - 3.2 VR6 R32
Success!!!

It will not work on my laptop with a serial card...apparently the actual BIOS of the laptop will not even recognise this card as COM1 - even though windows sets it up okay and operational.

I transported my entire home computer down to the garage and it worked first go off the proper serial port on my computer tower.

I want to give a big thanks to mtltdi, compu_85 for all their help and especially madelgado for all his extra research on behalf of all of us.:cool:

TeleDawg rates a very special mention for sending me a special boot file that meant I didn't have to press any buttons to get it to work. :)

I used this cable, bought off ebay by the way:

http://cgi.ebay.com/ebaymotors/Serial-KKL-Vag-Com-Cable-Interface-VW-Audi-Scanner-VAG_W0QQcmdZViewItemQQcategoryZ43989QQihZ018QQitemZ280086487311

ebay seller is chiltonsondemand

I have a right hand drive three door R 32 with comfort control
module 1C0 959 799 B with interior monitoring and alarm.

Coding was:

4361 10 > 2
4362 10 > 2
4363 10 > 2

Hold Fob button to wind up/down windows (no one-touch)
 

mtltdi

Veteran Member
Joined
Apr 1, 2003
Location
Canada
TDI
2003 Golf GLS, Indigo Blue
That's the same seller I use to get my KKL cable. quick service, good product.
 

Graeme

New member
Joined
May 3, 2005
TDI
1.9 TDI PD 90bhp
Correction to jim22 post:

Many thanks for this, it works a treat.

I've done two cars:

2002 UK RHD 2 Door Golf IV GTI
CCM Module 1C0 959 799B
04361 10 >> 2
04362 10 >> 2
04363 10 >> 2

2003 UK RHD 4 Door Leon Cupra-R
CCM Module 1C0 959 799F
04361 10 >> 2
04352 10 >> 2
04363 10 >> 2

Windows open and close by holding remote button - I'm guessing there is no way to make it one touch lock + close, is this correct?
I have just done this on my 2003 seat leon cupra 1C0 959 799 F and it works fine, but as per JIM22 post the 2nd line for the leon is incorrect:

04352 10 >> 2
It should be :

04362 10 >> 2

like the golf he listed above...

so for seat leons you should use this programming:

2003 UK RHD 4 Door Leon Cupra-R
CCM Module 1C0 959 799F
04361 >> 10 >> 2
04362 >> 10 >> 2
04363 >> 10 >> 2
 

Mickski

Member
Joined
Mar 15, 2007
Location
France (93)
TDI
None : 1.8 20VT ;-)
Graeme said:
so for seat leons you should use this programming:
2003 UK RHD 4 Door Leon Cupra-R
CCM Module 1C0 959 799F
04361 >> 10 >> 2
04362 >> 10 >> 2
04363 >> 10 >> 2
I did it onto two Seat Leon 1.8 20VT yesteday evening using VDS-Pro and it works great.

With a little difference anyway.


The first 20VT has embedded 1J0 959 799 AH Comfort module.
The second 20VT has embedded 1C0 959 799 F Comfort module.
On the first one, I could enable all four electrical windows or only the one(s) I wish to operate with the remote.
On the second, I could enable all four electrical windows or none. No selection possible.


I have to do new attempts. For example, the selective central locking is enable on the first 20VT, not on the second. Maybe this setting alters the behaviour ?


Furthermore, for the 1J0 959 799 AH module, the settings I found are :
Memory Address / old value / new value
04283 / 8 / 2
04289 / 8 / 2
08628 / 242 / 246 driver side front window
12724 / 250 / 254 passenger side front window
16820 / 250 / 254 driver side rear window
20916 / 242 / 246 passenger side rear window


But for the more recent 1C0 959 799 F module, only two addresses had been modified :
04361 / 255 / 2
04362 / 255 / 2
At addresses 12724, 16820 and 20916, totally different values are coded. So, I assume that different ones should be used for this module but I'm still looking which ones... :p


madelgado, you've done an awesome job !

I'm waiting for a trick to operate electrical mirror with the FOB too ! :)
 
Last edited:

Rodrigues

Veteran Member
Joined
Dec 5, 2006
Location
Detroit, MI
TDI
None
Maybe somone can help me, I have done this mod on 3 2001 Jetta's with the AJ CCM. The 4th car I tried to do it on (2001 Golf w/rocketchip as well as the AJ CCM) fails to connect to the CCM. It detects the ECM and shows "Rocketchip" with some other info at the bottom of the screen but when I try to log in (19283). Any ideas why this would work on 3 01 stock TDI Jettas but not a modified 01 Golf with the same p/n CCM and a rocketchip mod?
 
Last edited:

Occams_Razor

Veteran Member
Joined
Jun 27, 2003
Location
Dayton, Ohio
TDI
Jetta Wagon, 2003, Reflex Silver
You would only see Rocketchip if you are logged in to the Engine Control Module.

The Convinence Control Module will just show you the part number of the CCM.

Rodrigues said:
Maybe somone can help me, I have done this mod on 3 2001 Jetta's with the AJ CCM. The 4th car I tried to do it on (2001 Golf w/rocketchip as well as the AJ CCM) fails to connect to the CCM. It detects the ECM and shows "Rocketchip" with some other info at the bottom of the screen but when I try to log in (19283). Any ideas why this would work on 3 01 stock TDI Jettas but not a modified 01 Golf with the same p/n CCM and a rocketchip mod?
 

Rodrigues

Veteran Member
Joined
Dec 5, 2006
Location
Detroit, MI
TDI
None
Simply starting up the program started me in the engine it looks like then. Could the login be something other than 19283?
 

jim22

New member
Joined
Oct 12, 2006
Location
UK
TDI
MKIV Golf GTI
Graeme said:
Correction to jim22 post:



I have just done this on my 2003 seat leon cupra 1C0 959 799 F and it works fine, but as per JIM22 post the 2nd line for the leon is incorrect:



It should be :

04362 10 >> 2

like the golf he listed above...

so for seat leons you should use this programming:

2003 UK RHD 4 Door Leon Cupra-R
CCM Module 1C0 959 799F
04361 >> 10 >> 2
04362 >> 10 >> 2
04363 >> 10 >> 2
Corrected in original post, sorry for the typo.
 

Nuje

Top Post Dawg
Joined
Feb 11, 2005
Location
Island near Vancouver
TDI
2002 Golf 6MT; 2015 Sportwagen 6MT; 2016 A3 e-tron 6DSG
Damn....so close!! Update: YAY!!!

Dug out an old busted up laptop at work and booted into DOS (F8 as Win98 starts to boot).

I got all the way to the Login, but when I get to the "46" page, I don't have options above "15".
(I think Login is "11"; something is "15", and then that's all that's on my screen. No 26 or 27 or ANYTHING in the 20's.)

Any idea what's the problem? Do I have the wrong config file? Could someone email or pm me the config file if that is the case?

I did manage to see that my CCM is 1C0 959 799C 1Q (this is in a 2002 Canadian Golf).

So, I think I'm doing:
Mem Address / Old / New
04361 / 138 / 66
04362 / 138 / 66
04363 / 138 / 66

Am I heading in the right direction?

Any insight available?

Thanks, kids! :)
Mike
----------------------------
24 hrs. later......
Turns out the issue was the bad config file. Got a new one from compu85 (thank you, Jason!!). Did as mentioned above.....SUCCESS!!!! That is just way too freakin' cool!

And proof yet again why this is this is the best board anywhere - thanks for all the info and help and same to all those who did all the groundwork and research on this!
 
Last edited:

Nick W

New member
Joined
Apr 28, 2007
Location
West Mids, UK.
TDI
Passat 2001 130 TDi Estate (Wagon)
Madelgado,

Did you have nay luck with the coding for one-touch auto windows?

I finally got a loptop that would work and have re-coded to enable window closing by holding down the close key-fob (and open of course).

Would really like to find the combination for the one-touch. I'll do some playing if I can get hold of a workinh laptop for a while.


Thanks,

Nick.
 

Nate_Grauvogel

Veteran Member
Joined
Feb 10, 2005
Location
CO
TDI
'15 T-Reg Exec
Nuje said:
Dug out an old busted up laptop at work and booted into DOS (F8 as Win98 starts to boot).
FYI - I'm almost done configuring a brand-new Lenovo (nee IBM) X60 Tablet for VDS-Pro... I bought the slim dock (with RS-232 port!!) and am using a bootable USB thumb drive to load up DOS. So far, I've formatted the USB drive with HP's USB disk format utility to make it spoof a bootable floppy using WinMe DOS boot disk files, and can boot up into DOS and run VDS-Pro with no problems. When booted that way, the boot partition on the usb drive becomes C: drive, and the rest of the usb drive is recognized as D:... :) sweet.

If I didn't have an '07 Jetta (CAN-only!) as a loaner right now, I'd have tried it out already and posted full results. I'll post the rest of the story soon...
 

Nate_Grauvogel

Veteran Member
Joined
Feb 10, 2005
Location
CO
TDI
'15 T-Reg Exec
Follow-up: My new laptop works! I'm using a bootable USB Thumb drive and the docking station, which has a native RS-232 port... it is so much easier than using the old machine. It's just nice to know that you don't absolutely have to resurrect old hardware to use VDS-Pro.

Nate_Grauvogel said:
FYI - I'm almost done configuring a brand-new Lenovo (nee IBM) X60 Tablet for VDS-Pro... I bought the slim dock (with RS-232 port!!) and am using a bootable USB thumb drive to load up DOS. So far, I've formatted the USB drive with HP's USB disk format utility to make it spoof a bootable floppy using WinMe DOS boot disk files, and can boot up into DOS and run VDS-Pro with no problems. When booted that way, the boot partition on the usb drive becomes C: drive, and the rest of the usb drive is recognized as D:... :) sweet.

If I didn't have an '07 Jetta (CAN-only!) as a loaner right now, I'd have tried it out already and posted full results. I'll post the rest of the story soon...
 

madelgado

Veteran Member
Joined
Dec 7, 2006
Location
Spain
TDI
Passat 3BG 2001
Nick W said:
Madelgado,

Did you have nay luck with the coding for one-touch auto windows?

I finally got a loptop that would work and have re-coded to enable window closing by holding down the close key-fob (and open of course).

Would really like to find the combination for the one-touch. I'll do some playing if I can get hold of a workinh laptop for a while.


Thanks,

Nick.
Hi, long time since I do not follow up this thread... very busy at work, sorry. Well, what I am really looking for is for the bit to fold/unfold mirrors with remote... but in the way, as I am testing all bits and checking any new/missing functionality for every bit, I am sure that I will find it. There are 45 configuration bytes in each power window motor. I have tested about 10 bytes (which is 80 bits). I found bits to enable/disable folding mirrors, heated mirrors, auto-close/auto-open of windows, to invert the window switches in the door (so that up means down, etc), and some others. One of the things that I am testing also is the auto-close feature, but did not come yet. I am documenting every bit that does something and I will soon publish all my tests when I complete the all 45 bytes.

I also made a small break about the CCM to build my Gamma + PocketPC, which I hope that you had a chance to see... It toke me more than one month at home. This is all I can say by now. Best Regards.
 

Nate_Grauvogel

Veteran Member
Joined
Feb 10, 2005
Location
CO
TDI
'15 T-Reg Exec
Wow, Madelgado, you are definitely an asset to the community.

And you also must not have kids... ;) or you have a very understanding wife. :D

I wish I had that amount of free time still.

Thanks for all your work!

madelgado said:
Hi, long time since I do not follow up this thread... very busy at work, sorry. Well, what I am really looking for is for the bit to fold/unfold mirrors with remote... but in the way, as I am testing all bits and checking any new/missing functionality for every bit, I am sure that I will find it. There are 45 configuration bytes in each power window motor. I have tested about 10 bytes (which is 80 bits). ...

...I am documenting every bit that does something and I will soon publish all my tests when I complete the all 45 bytes...
 

tbcuprat

New member
Joined
May 17, 2007
Location
UK
TDI
Seat Leon Cupra R MY03
Hi Guys,
Excellent thread and a lot of information to digest.
Unfortunately there seems to be a dead link to compu_85's VDS Pro files in post #23.
Not such a problem as I have the application but I think I'm missing the all important vd.cfg
Could someone please post the contents of this file. It would be much appreciated.

Cheers
Tony.
 

compu_85

Gadget Guy
Joined
Sep 29, 2003
Location
La Conner, WA
TDI
... None :S
My server bit the bucket the other week. I hope to get this up again soon. The link will be restored. If anyone needs this file, please send me an email. My email is listed in my profile.

-Jason
 

cornel

Member
Joined
Jun 1, 2007
Location
Norway
TDI
tdi
Is there no way to get this to work with USB cable?
I have the 704.1 release of the VAG-COM program.
I have this cable: http://www.ross-tech.com/Merchant2/merchant.mvc?Screen=PROD&Product_Code=VCHUC&Category_Code=VAGCOM




I dont have any seriel cable or seriel port on my computer! *GRR*, but i have a cheap ebay usb cable to, maybe i can make a com - Serial cable out of that cheap cable?


Edit: I have the 1J0 959 799 AH module in my VW Bora 2000mod.

Isnt it this numbers you guys change in VCD-PRO? (sorry for big picture...)


 
Last edited:

kc5enu

Well-known member
Joined
Jan 17, 2006
Location
Lewisville, TX
TDI
2015 Jetta TDI SEL 6spd, Blue Silk Metallic
Working VDS-Pro eBay cable

cornel said:
I personally don't know of anyone who has used this cable, but I would imagine it will work. However, I have used one of these cables from this seller and it does work with VDS-Pro:

http://cgi.ebay.com/ebaymotors/Serial-KKL-Vag-Com-Cable-Interface-VW-Audi-Scanner-VAG_W0QQcmdZViewItemQQcategoryZ43989QQihZ018QQitemZ280119283229QQrdZ1

I have read other posts where at least one other person has used this cable successfuly also. Plus, it is a few bucks less than the one you mentioned.

Have fun with it. I personally love having the rollup (or rolldown, good for hot summer days) feature. It's well worth doing.
 
Top