BEW baby turbo build (pic heavy)

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
This is what started it all…diff blew up
And Suddenly this seemed like A good idea
It was 😈 ability to get out in traffic from a stop is GREATLY increased with that there LSD! (I got a 30 day Facebook ban for saying LSD regarding that part)

anyway next I built some headlights


then clutch was slipping which is really upsetting because it is a stage 2 daily by SB.
Turns out the tandem pump was leaking fuel in the trans inspection port causing random slipping. The leaking tandem pump was probably a result of the failed lift pump.
at the same time I noticed my cam shaft was ****…lame!!!

So It was around Christmas and I was given a stage 2 cam as a free upgrade.

after having the camshaft specked out at Delta cams in Tacoma Washington I determine it’s worth installing and this happens
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Tapping EGT I suggest going a little higher than I did. I got almost in the middle of the E which is Perfectly In the middle of the turbo exhaust plumb but it is VERY close with the intake manifold, I will not be able to change the EGT probe without removing the manifold.




this plug must be put here by VW for gauges! It runs straight to the steering wheel, you have to pull the lock metal kick pannel first.



no pics but if you want them to turn on with the lights and the dimmer to function you pull the dimmer switch snd use the grey wire with the blue stripe to power your gauges. I’m using blue led bulbs in my auto meter gauges. They look decent, and I measured them with my multi meter they’re only drawing.75ma so I should be fine without a fuse but I should use a small fuse just incase a wire breaks and arks.

this is more helpful than mehttps://axleaddict.com/auto-repair/How-Install-Boost-Gauge-Wires-MKIV-VWAudi-DIY
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Currently I’m waiting for a few bolts. I need to get a downpipe still. I have an MPPS cable in the mail. I have PD 150 pumps and an X man hybrid turbo to drop on still.
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
I don’t know what I was thinking, I know the VR6 doesn’t have a turbo, but everywhere I read it says you can use a VR6 airbox in place of a PD 150 airbox. That is incorrect ! It needs 2 modifications!
1) a vacuum port needs to be added to the vr6 box for n75 operation.
2) the sai port blocked
I did both with one part. There’s many ways to do this.

So here is my is my vr6=pd150 air box mod

The vr6 has the SAI port
that will need plugged.
I used with a tapered rubber plug.
It is sized 28-32 mm or 1-1/8 - 1-1/4.
I drilled the plug 1/8 npt fitting then used a vice grip to screw it in place. It’s a VERY tight fit bit course I jammed my little plug in the hole, oOo Yah !


View media item 145624



I smoothed into the airbox out after seeing some data that indicated I would gain about 5 g of air st 3000 rpm (that’s nothing but still measurable )

Now, I think I should modify the bottom of the air box too , that flap door is weird. With the OEM filter creates a restriction until the flapper and then it’s a factory hot air intake! Honestly had i known that I may have said screw itand thrown a cone filter on there for easy of installation and the extra room (which is the reason I almsot did in the first place)

Also, This is the maf housing I used cuz I could not get my hands on a vr6 Housing for a fair price. Pickin and pull wants 30 bucks for one of these stupid things and get a new one cheaper snd return it easier so I did.
UDATE, the Volvo maf worked BUT the plug does not reach haha so it had to be extended , easy way was to hack one off the wrecking yard and grab the extra length wire. I almsot unwired the entire harness but that’s a STUPID can of worms I’d rather hack it haha AND no one will ever know unless the read this thread
 
Last edited:

Nero Morg

Top Post Dawg
Joined
Oct 19, 2017
Location
OR
TDI
2014 A6 TDI, 2001 Jetta TDI, 2014 Passat TDI
Well that's some neat modding. Don't forget to tune for the different maf housing size. Can't wait to see it on the road!
 

Nero Morg

Top Post Dawg
Joined
Oct 19, 2017
Location
OR
TDI
2014 A6 TDI, 2001 Jetta TDI, 2014 Passat TDI
No not yet. But I also forgot to check the mail yesterday. Too busy working on a 7.3 idi
 

TurboABA

Veteran Member
Joined
Jul 24, 2010
Location
Kitchener, ON
TDI
RIP-2010 Jetta 6spd 2014 Touareg Execline
"Pic Heavy" :sneaky: said no one ever!


Reminds me of when I used to browse on dial up connection....
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
No not yet. But I also forgot to check the mail yesterday. Too busy working on a 7.3 idi
Nice my neighbor snd overall VAG guru has one of those with a 5 speed. back in the day a good friend of mine had a 92 power strok. That thing had like 18” of lift and cleared 48” with lots of room to spare …it was alot of fun rolling around in that pig! It’s his fault I got into diesels but my grandpa was panting to with the vw idi rabbits. My mom loved me. She was proud of me when I got a diesel lol and started learning.

"Pic Heavy" :sneaky: said no one ever!


Reminds me of when I used to browse on dial up connection....
I kind of miss those days. Now it’s so fast…were sooooo connected, it slows me down some days especially when I get spreading myself too thin.
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Nice updates!
What EGT probe did you use?
Thank you, the car should be A whole new car when I’m done. It’s an auto meter probe.

I’m having some hiccups waiting for my exhaust now because of the war it’s stuck in customs in Germany .

It’s just been one little thing after another hopefully I’ll be done by the end of the month.
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Well, done waiting for exhaust , finally went ahead and finished things up snd took it for a test run.

It ran well

Sadly I did not Save the log correctly. I warmed up the car for about 20 minutes before driving. Then I drive pretty easy, but eventually I did get the boost maxed out , 21 psi the held around 18.


I did not exceed 800 degrees in the EGT, and the gauge seems to be very accurate , moves pretty quickly as expected.

As expected it feels a bit doggy with the hybrid turbo and the current fueling…
It is LOUD but that’s probably from the air box mods. Above 3k (which I barley touched) it’s annoying I almost thought something was Finns break lol but I’ll get use to it haha hopefully more fuel changes that.

Given the smoke free performance I have a feeling I could just drop the pd150 nozzles in and it would wake it up, but the boost needs to be turnt up too. I might go ahead and test it with the nozzles just before I install the tune cuz why not.

Have a bit of tidying up to do and the damn door actuator failed now haha just my luck. The worst thing is, as I was putting the bumper back on letting the car warm up, I was in kind of a hurry and I dropped one of the headlights off my shelf. and the inner adjustment arm broke so my headlights are aimed all stuoid now. It was an easy fix but a wast of time.
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Because I have not seen comparisons for EGT before downpipe and exhaust and after bold designates after
What I’ll say is it does. It really go done a whole lot but it reduces temperature MUCH faster when you let of the fuel.

*Coming up a mile long hill climb 65moh in fourth gear EGT is about 800°. in fifth gear I touched over 1000° Very easily now I have to be logging in 4th gear comming up a bill to crack 1000f stays much cooler much longer and recharges much faster, I think that’s FMIC working


*cruising along at about 2300 RPMs I made between 600 and 800° on the EGT holding steady at about 10 psi. More like 600

*Highway cruises EGT sits between 5-700 on I5 in congested SeaTac area. Remains about the same in traffic.

*Cursing around town. 5-600 degrees. driving pretty steadily, About the same idle at traffic lights it drops little lower the. Before 370ish.

Going up hills I regularly hit 1000° and then I start to back off. pulls on the highway from 60 to 80. EGT goes up to 1200 very fast. Takes a WAY longer to get to 1200 now :) coming up the same mile long hill mentioned above (I backed off at first in cuz it gets hot fast) I hit 1100 aroind 90.
I really NEED a tune so I can enjoy this car.


I also set the timing KW to -1 from +.5 seems and st slow speeds it to have a slight stumble. Might have a slight improvement in efficiency. I will move it toward -.5 or 0 and leave it there.

it still Looks like I’m still getting about 35 mph IN TOWN but i was not able to accurate calculate when I filled up today. went to 36 for 3 fillips.

ALSO 5.50$ diesel is BS
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Update, finally got the 2.5” straight back done. Diesel profi sucks!
First off it don’t look like the picture. It comes into pieces, and is attached with band clamps. Then you will see that the mount didn’t fit and I had to bend it,. Also when it just goes together it points straight down at the ground LOL. The exhaust fabrication shop didn’t even use the piece of stainless steel they sent me. I suppose I’ll sell it





In contrast, I had the ID parts one on my last car and I put that sucker on myself too, and, man it was a beautiful thing just bolted right up and nearly mated to the factory exhaust which I deleted lol


Alamo there! I’m having tuning issues cuz of an encrypted file.
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Got my pd150 nozzles installed today. IQ deviations is bad nearly 3. (Update) It ended up being hardware shown by swapping injectors 2 snd 3. DISSELFIXINS sent me a remanded nozzle , I paid again :( and the problem is solved so one injector was not calibrated well.




Finally found a tune. my “stock” tune was encrypted snd no US tuner can touch it.

Luckily a cool cat named Stewart from a tdi ecu tuning group was able to decrypt it.



FADR tuning. Honestly, he worked with me a lot on boost logs but outside of the first day IQ issue I never got any updated tunes from him.

I noticed before the tune that boost builds nicely then Drops and then it builds and creeps up. It still does that I must have a slight boost leak somewhere? I’ll be hunting…edit found it the vnt 17 adapter o-ring was shot. I think I used a 41x4mm instead of the 44x3.5 and it sealed perfect.(edit again) that o ring and leak did NOT fix the boosting issue. I wonder if this is the bee boost creep you here about ?
 
Last edited:

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
So I decided to clean up some wires…I finally extend the MAF wires , and chopped the o2, the Egr, smart actuator and n18 harnesses off.



After that this car tried to kill itself again. Then I leaned about the stupid break switch issue with the mk4 chassis. Lol I was pancaking for a few days. Almost thought I the ECU somehow , but the coolant glow plug harness was damaged.


Tonight I heat shrinked and tucked all the wires away. Car still looks OEM.there shoold be nothing that can rub.
 
Last edited:

Hyde7278

Veteran Member
Joined
Nov 11, 2012
Location
Central Mich
TDI
2001 Golf GL
Update, finally got the 2.5” straight back done. Diesel profi sucks!
so next thought…What will happen if I drop my pd150 pumpsbefore a remap?

I’m having tuning issues cuz of an encrypted file.
If you dont mind me asking what problems did you have with the dieselprofi exhaust. as I was looking into getting one.

Thanks Sean
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Hey Sean, I updated that post ,thanks for saying something. Those pictures almost got lost :)

 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Setting up the actuator snd stop screw is really a PIA when trying to get perfect even boost! I’ve been all over the place tryint to get the h/w perfect. I’ve got 3000 miles on this car now and it’s gettint 36mpg city driving arounf doing a lot logs. I have yet to do a highway run lol why do I drive a TDI again??? The thing stinks and it’s kinda loud imho. I also replaced the drivers seat with a heated GTI seat. I Fixed the heat temp selector as it fell out
 

dhangejr

Veteran Member
Joined
Mar 1, 2017
Location
PNW is my home
TDI
mk4 Jetta
Build thread updates


Did this ^ to hopefully solve Smokey cold starts. Soon I’ll see if it works.( edit nope )

Replaced coolant temp sensor and harness just cuz it was NON OEM and the harness clip was broken and the thing was dripping coolant.

I also Covered lots of wires with Tesa tape including the coolant glow plugs. Next I think I’ll repair the glow plug harness with this stuff , it’s great!


A while ago I finally got the turbo set up right. So the Turbo is boosting (slow AF) again. It peaks to about 25 settle to 22. Fueling is still a little high on one cylinder. compression test needs to be done.

I also replaced the injector harness, it was leaking oil, I was gonna silicone it but I got pissed at the car and smashed the old one. I cleaned the cabin air filter, snd replaced the air box filter. I replaced the VC gasket snd used a little rtv .cuz I think oil may have been seeping here too. I Did an oil change (rotatella t6)

next I’m doing a tranny fluid flush (the LSD now has 10k miles maybe more) and a fuel filter again and whatever else drops up (hopefully nothing) car is running ok!

Will have to report back and see if it starts Better when below freezing soon. -NOPE **** this car 😆
 
Last edited:
Top