Battery charge now check engine light??

TdiRN

Veteran Member
Joined
Jul 7, 2015
Location
FL
TDI
2002 VW Jetta, 5 speed, 352k miles
Charged my battery in the car over the weekend. I have the amp draw issue but that is another issue for another time. After I got done charging the battery my check engine light came on with the Auto transmission codes - I did the 5 speed swap 70k miles ago. I used vagcom and went in and the transmission is still coded to manual. I've cleared the codes several times but they keep coming back.

Any ideas?
 

eddieleephd

Top Post Dawg
Joined
May 27, 2012
Location
Asheville, NC
TDI
2002 jetta Wagon
I would assume you disconnected the TCU, if not that could be the culprit. Mine still says no comm with TCU.

Sent from my Armor_2 using Tapatalk
 

TdiRN

Veteran Member
Joined
Jul 7, 2015
Location
FL
TDI
2002 VW Jetta, 5 speed, 352k miles
I haven't had any engine lights in the last 3 years until sunday. If the TCU is unplugged - what would have caused it to suddenly start throwing codes?
 

boertje

Veteran Member
Joined
May 24, 2002
Location
Coeur d'Alene, ID
TDI
'01, '01, '03 - TDIs all.
When you did the swap, did you also set the can bus? I see you have a 2002 where is shouldn’t be necessary, however some are problematic.

On MY 2001 and earlier, go to CAN-bus gateway>coding and change the 7 to a 6 to remove the automatic transmission feature.
Look at the last digit in the coding. Add the values for the options together to get the correct coding.
0 - No available equipment
 +1 - Automatic Transmission
 +2 - ABS Brakes

+4 - Airbags
So, if you want to support Automatic Transmission, ABS Brakes, and Airbags, (add 1+2+4 = 7) = 00007. Note: 2002+ models do not need to be coded separately for automatic transmission, so a 2002 with Automatic Transmission, ABS Brakes, and Airbags, (add 2+4 = 6) = 00006. In my Golf, the coding was 7 so I changed it to 6 which subtracted the automatic.
Not necessary on MY 2002 and later. However, It has been discovered that some 2002 and later cars are having TCU communications error codes even though the wiring and coding was done correctly. If the 19-CAN Gateway is checked with these cars, the value is 6 as it should be. What is interesting (thanks to “the*rogue” for this one) is that if the value is changed to a 6, which it already is, and saved, it forces the ECU to rescan the devices and finding no TCU, it is now happy and the codes do not reappear.
Make sure you cycle the key after each change and then check for fault codes.
 

TdiRN

Veteran Member
Joined
Jul 7, 2015
Location
FL
TDI
2002 VW Jetta, 5 speed, 352k miles
Honestly I had a VW shop do the swap. So I can't be 100% sure.

If I go in there and change the can-bus to a 6 (assuming it hasn't been) would that mess anything up?
 

BobnOH

not-a-mechanic
Joined
May 29, 2004
Location
central Ohio
TDI
New Beetle 2003 manual
.............................. I have the amp draw issue but that is another issue for another time........................

Any ideas?
Maybe that draw is one of the TCU wires shorting or grounding and the ECU sees that.
 

boertje

Veteran Member
Joined
May 24, 2002
Location
Coeur d'Alene, ID
TDI
'01, '01, '03 - TDIs all.
Honestly I had a VW shop do the swap. So I can't be 100% sure.

If I go in there and change the can-bus to a 6 (assuming it hasn't been) would that mess anything up?
No, it won’t mess up anything. It most likely will already be 6 but the key is to get the ecu to rescan so “change” it to 6 again and save.
If the 19-CAN Gateway is checked with these cars, the value is 6 as it should be. What is interesting is that if the value is changed to a 6, which it already is, and saved, it forces the ECU to rescan the devices and finding no TCU, it is now happy and the codes do not reappear.
Make sure you cycle the key after each change and then check for fault codes.
 

TdiRN

Veteran Member
Joined
Jul 7, 2015
Location
FL
TDI
2002 VW Jetta, 5 speed, 352k miles
Should the TCU be plugged in OR unplugged
 

TdiRN

Veteran Member
Joined
Jul 7, 2015
Location
FL
TDI
2002 VW Jetta, 5 speed, 352k miles
I did the CAN/bus thing last night. This morning the light was still off so we will see.

On a semi-related topic is it possible to disable the driver seat side airbag with Vagcom?
 

TdiRN

Veteran Member
Joined
Jul 7, 2015
Location
FL
TDI
2002 VW Jetta, 5 speed, 352k miles
Damn light came back on. I do have a glow plug code which I need to fix. I wonder if whenever a legit code is thrown it will pull all 20 codes for the auto tranny?
 
Top