ALH Low power around 3000rpm

Mavrick

Veteran Member
Joined
Feb 16, 2012
Location
Ontario
TDI
2003 VW Jetta TDI
2003 Jetta TDI Wagon
5 Speed converted

Drive ability is great if under 3000rpm and not pulling up hills. When it hits 3000rpm (or less if under load in 5th gear), MAF drops to 600-650ish and boost drops to 1400-1500mbar. If you keep it under WOT the boost and MAF come back around 3400rpm. I'm out of idea's as to what it could be besides maybe worn vane mechanism inside the turbo, but I haven't seen these symptoms before. Maybe ill try zip tying the ASV shut for a road test. Otherwise have gone through everything..

New timing belt, timing is bang on, advanced slightly
Removed snow screen and catalytic converter
New air filter, new fuel filter, pickup in tank is spotless and clean
Tried a couple different used MAF, N75, replaced vac lines
Vacuum pump is pulling a strong 30"
Vac actuator works well. Pulling at 5" and maxing at 20"
Vane lever is very free
Unplugged EGR for a road test, same results

Of course, no codes.

Any ideas?
 

mxracer291

Vendor
Joined
Jul 7, 2015
Location
Freeport, Illinois
TDI
2000 VW Jetta TDI
I have almost identical symptoms. I planned to clean my intake manifold soon to see if that would fix the issue! Keep this updated if you find something else. Thanks!
 

UhOh

Top Post Dawg
Joined
Dec 24, 2014
Location
PNW
TDI
2000 & 2003 Golf GLS
My car struggled around 2,400. Cleaned intake manifold (etc.) and instantly became like new! Pretty much have to take off the EGR valve to get a good look at the status of the intake manifold: it's fairly easy.
 

Mavrick

Veteran Member
Joined
Feb 16, 2012
Location
Ontario
TDI
2003 VW Jetta TDI
Stock engine. Forgot to add.. intake was not plugged but was replaced with a clean manifold "just in case."

TPS does not move from 100% when wide open, including when the power loss occurs.
 

Vindiesel6

Veteran Member
Joined
Jul 14, 2003
Location
Northern, NJ
TDI
2002 VW Golf GLS TDI & 2015 Q5 TDI
I had a similar power loss issue above 3k rpm. It was traced to a boost leak at the MAP sensor port on top of the intercooler. Check for any oil residue at intercooler pipe connections too.
 

mxracer291

Vendor
Joined
Jul 7, 2015
Location
Freeport, Illinois
TDI
2000 VW Jetta TDI



Here is a log graph of 2 pulls through my dead spot, looks too be like a sticky actuator or turbo vains!

Sent from my LGLS991 using Tapatalk
 
Top