A6 CPNB Stuttering

TurboDieselPoint

Veteran Member
Joined
May 16, 2012
Location
N/A
TDI
2014 Passat TDI SE 6-Speed Manual
Over the past 10-15K miles, my 2014 A6 CPNB has gradually developed a stutter. My car feels as though it is misfiring/stuttering intermittently for the first 10 minutes or so after a cold start. I get the feeling it is tied to whatever emission warm up mode it performs.

I’d say the stutter is getting worse/more frequent. It is most noticeable in the lower gears, such as when I am taking off from a stop light. On the rare occasion, my engine will fail the first start attempt after stopping the engine at a red light with the “auto start/stop system.” It will have to pause and retry before I can drive off, which is admittedly alarming.

Else, the car is flawless. It has had no issues in its 125K miles. The last VCDS scan about 5K miles ago showed zero issues, but I’ll do another soon.

Thoughts? Has your car done this?

2014 A6 TDI CPNB 3.0
125K miles
Has had emissions fix performed
Has 23Z8 recall performed

Thanks
 

PeterA1

Active member
Joined
Feb 21, 2022
Location
Seattle Area, WA
TDI
16 A6 3.0TDI
Have you replaced your battery and had it coded correctly yet? These cars have some strange issues once the battery starts going bad. I did mine on my 2016 around 100k miles and it fixed a ton of strange electrical issues and I never use auto start stop anymore to avoid having to pull the motor to get to the starter if it goes out.
 

oilhammer

Certified Volkswagen Nut & Vendor
Joined
Dec 11, 2001
Location
outside St Louis, MO
TDI
There are just too many to list....
Injectors.

First, try some good injector cleaner (the kind you put in the tank).

Next, or along with the above, re-enter all the injector calibration numbers.

If that doesn't help, you can try some injector purge (this involves tapping into the plumbing of the fuel system and running the engine entirely on the purge product itself for a few minutes).

If all else fails, you may end up having to replace the injectors.
 

TurboDieselPoint

Veteran Member
Joined
May 16, 2012
Location
N/A
TDI
2014 Passat TDI SE 6-Speed Manual
I was terrible about following up. Thank you both for your suggestions.

@PeterA1 I did, in fact, put a new genuine battery in the car early this year. I also coded it with VCDS. Did not seem to affect the issue, but good suggestion.

@oilhammer What fixed it was changing the fuel filter, interestingly. I did my every-20-K service and the sputter vanished. It has been nearly a month now. No stutter.

I don’t have a very warm and fuzzy feeling thinking that apparently my fuel filter was so plugged up (perhaps even full of water?) that my car was struggling from a fuel delivery standpoint during the warmup modes. At least now the sputter is gone.

I wish I had saved the fuel from the old canister, but it went straight into my used oil pan.
 

Midwesthick

Veteran Member
Joined
Oct 26, 2011
Location
Denver
TDI
A3, GSW, 02-Golf
Good call on replacing the fuel filter.

I personally fill my canister up with a diesel purge, turn the car on and let it run for 30 seconds and then just let it sit for about 30+ minutes and then take it out. No issues doing it this way.
 
Top