2006 sticking Jetta brakes, where to start?

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
For numerous unrelated reasons, my 2006 Jetta sat here in my driveway in Florida's rainy season for 2 months without being used at all. I went to use it today and discovered that the brakes no longer reliably release correctly. I let off the brakes while coasting and they act as though I am still mildly or even somewhat firmly depressing the brake pedal. I was able to use the engine and clutch to make forward motion, but it was unnerving.

I was able to get to a safe spot and had AAA tow it back to the driveway. The tow truck driver observed that when releasing the parking brake, it rolled back off the truck without any apparent issue.

Both front and back rotors and pads were changed to new last year, during a major overhaul including a cam, timing belt, front axles, one wheel bearing and various other random issues.

I solicit your ideas as to where to look first, as I no longer have the luxury of being able to throw unlimited time at diagnosing issues or optimizing solutions. And yes, I have changed the brake fluid regularly as recommended, although it is now a little past due.
 

goodmonkey

Veteran Member
Joined
Mar 20, 2006
Location
Anchorage, AK
TDI
2014 Passat TDI, 2011 Touareg TDI
It may be just one brake that is stuck. In my experience, when the parking brake freezes (water in the cable sheath freezes) it will roll backwards but feel bad going forward. If you can jack up each side safely you might be able to figure out which wheel it is by spinning by hand. Could simply be the slide pins on one of the calipers is rusted in your case.
 

James & Son

Veteran Member
Joined
Oct 10, 2008
Location
Maryhill, Ontario, Canada
TDI
2006 Jetta
When you said you just did pads and rotors that has happened to me. Means you have to replace the offending caliper or calipers that are dragging( re-manufactured worked find for me). Since you replace your brake fluid I am surprised though, I just assumed since I replaced fluid only once in cars life( 2015) I would have that problem.

Could check into collapsed brake hose, although personally have never had that happen.
 

Mach1

Vendor , w/Business number
Joined
Sep 27, 2005
Location
Spicewood, Tx.
TDI
05.5 Jetta 5 spd, 06 Jetta DE DSG, 04 F250 6L, 2000 F250 7.3L
These rotors rust pretty good and I see the same thing if my car sits more then a couple days and its humid or raining. It takes a couple of good brake applications and/or a reverse brake application to knock the rust off and probably a couple of miles to clear the rotors completely...I would try this first before tearing into it.

I have seen the pads 'rust' to the rotors and it took a good bit of force to release them...

good luck with it..
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
Did not have time to work on it until today, and then only to move it to a different spot on the driveway. The problem is now much worse, but seems actually to be related to the pedal and master cylinder, as the pedal does not come back up unless pulled up. I will investigate what air exposed components related to the master cylinder could account for such behavior.

This is doubly frustrating because the rest of the car all works fine, it throws no codes and the engine runs beautifully.
 

where2

Veteran Member
Joined
Oct 29, 1999
Location
North Palm Beach, FL, USA
TDI
One '13 JSW_TDI & One '04 Variant_TDI
Did not have time to work on it until today, and then only to move it to a different spot on the driveway. The problem is now much worse, but seems actually to be related to the pedal and master cylinder, as the pedal does not come back up unless pulled up. I will investigate what air exposed components related to the master cylinder could account for such behavior.

This is doubly frustrating because the rest of the car all works fine, it throws no codes and the engine runs beautifully.
I'm 2.5 miles (as the pelican flies) from the Atlantic ocean. If I don't drive one of my cars for a week or two, I'll get surface rust on the discs, but that usually wears off in a few miles of stop-n-go traffic. It's certainly worse if the car sits uncovered in the driveway where it gets rained on, but even sitting in my father's carport where two of the rotors aren't getting rained on, they will surface rust.

Start by checking your fluid level. My experience with non-returning pedals is that there's a fluid leak somewhere. Replace the offending hose or caliper.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
The behavior I have observed could be explained by a problem with the valve that releases vacuum from the servo when the brake pedal is released. Has anyone here had a problem with their servo, aka brake booster?
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
This car an its brakes are now working fine again. I did not definitively identify the cause of the problem, but the following events occurred:

I jackstand all 4 points so all the wheels would be off the ground. Initially, the problem was still there, however, after a bit of time, the problem disappeared, although I don't remember whether or not I had left the reservoir cap off or not while testing the second time. In lieu of actually identifying the cause, I decided to change the brake fluid, which turned out not to be particularly bad, only slightly greenish. During this time, I noticed that the fluid reservoir seemed to have been too full. I did not pay this much mind, as although the shop manual says never to overfill it, it does not specify what would happen if one did so.

I bled clutch and all the brakes, front left, front right, back left back right in that order, per the Bentley manual. I tested the vacuum booster and found no problems, then put everything back together and found the car works perfectly now.

I suspect now that the original problem was probably due to an overly full brake fluid reservoir, caused in part by my failure to remove enough fluid after replacing all the pads and rotors, and part due to the much warmer weather in July than in April, when I had originally done the brake job.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
Oh no, the problem is back!


For various reasons, my 06 Jetta with 153k miles here in Florida got no use for a few months last year. When I went to drive it, the brakes would not fully release when the pedal was released. I changed the brake fluid, including the clutch and it worked well again. It then again sat outside unused for a couple more months and now the slow release brake pedal and sticking brakes problem is back. I jacked up the front of the car and tested the front wheels by applying the brakes to see if they would stick. They did not. I then repeated the test for the back wheels with the same curious lack of sticking. The pedal stll returns very slow. All the rotors and pads are fairly new. I am greatly puzzled. I have not yet checked the one way valve to the booster, but that is the next thing on my list.

I do still need to change a noisy front right wheel bearing. Could a funky wheel bearing actually be the cause of the drag, even though it doesn't pull when dragging?

Any suggestions are welcome.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
I would consider the wheel bearing an emergency safety repair.
This will be done shortly, although I have had experience with other auto bad wheel bearings that made noise for quite awhile without catastrophe prior to replacement.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
I replaced the brake hoses, which helped a great deal but did not fully resolve the issue entirely. As of now, the brake pedal comes back into original position too slowly, for unknown reasons. Here is a photo of the inside of the booster that seems to show a great deal of rust where I understand springs to be. Is this normal? Can I just spray some WD40 in there to 'fix' it? Advice is welcome.

 

06Jetta-Lane

Active member
Joined
Feb 23, 2019
Location
Memphis,TN
TDI
‘06 Jetta BRM
I went through a similar issue this past month that was gradually getting worse over time. I definitely had a bad rear drivers side caliper. 1 hot lap around the neighborhood and then shot each rotor with the infared gun. Both fronts were roughly 80F, rear driver 165F, rear passenger 115F. Went ahead and replaced both rear calipers and the grabbing definitely got better, but both rears still seemed to be grabbing and still biased to the drivers side. Removed both parking brake cables and found that both were not plunging in and out easily and the drivers side was beyond compromised. Replaced both cables and it completely fixed the grabbing issue. Been driving it for about a month and a half now with no repeat.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
My brakes are still pausing to release by about one to two seconds after the brake pedal is released. The car is drivable and used almost every day, but this is annoying and I still don't know what is doing this. There are no codes being generated and I have a VCDS which is not telling me what is going on here.
 

TurboABA

Veteran Member
Joined
Jul 24, 2010
Location
Kitchener, ON
TDI
RIP-2010 Jetta 6spd 2014 Touareg Execline
I read all this and my head hurts.
Put the vehicle up on a lift and\or stands. All wheels off the ground.
Then, attempt to spin each wheel. If there's any significant drag on any wheel, service\replace whatever component until the drag is acceptable. (wheel bearing, caliper, sliders, etc)
Depending on where that gets you, go inside and press the brake.... does the pedal release now? If not, check your pivot point and pedal assembly for anything causing it to hang.....
Report back.
 

Jbwoo

Well-known member
Joined
Oct 28, 2018
Location
Kingston WA
TDI
15 GSW 06 Jetta BRM
I have a exact same issue with the exact same age / try of car. Bleed the fluid, didn’t seem good. Problem still there. Tempting to replace the master cylinder. But watching what others do.
 

DivineChaos

Veteran Member
Joined
Jul 27, 2019
Location
Minnesota
TDI
mk6 jetta sportwagen tdi
I have a exact same issue with the exact same age / try of car. Bleed the fluid, didn’t seem good. Problem still there. Tempting to replace the master cylinder. But watching what others do.
First of all. What have you done? New pads, did car sit and rotors rust? How's your parking brake cables? Don't just throw parts at it.
 

Jbwoo

Well-known member
Joined
Oct 28, 2018
Location
Kingston WA
TDI
15 GSW 06 Jetta BRM
Car sat for roughly 14 months before I purchased it and put a new engine into it. I have checked all of the caliper slides, and lubricated them. Flushed the brake fluid as well. Before I did all of that, on the inaugural drive pulling out of the shop, the pedal stayed down as low I pushed it to stop, pulled it up with foot from behind, and progressively got better, but still sticks. I use the parking brake every day, and it holds well, and releases well.
 

TurboABA

Veteran Member
Joined
Jul 24, 2010
Location
Kitchener, ON
TDI
RIP-2010 Jetta 6spd 2014 Touareg Execline
I don't think you actually want to find the problem as there are tons of other components in the brake system on top of slides and fluid.
You have received all sorts of suggestions and question, but keep throwing random parts at it... You'll get it eventually.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
Well I finally stumbled upon the solution, but it still makes no sense to me. The vacuum hose between the vacuum pump and the brake booster had cracked awhile ago. I had 'fixed it' with some hydraulic hose and thought that was sufficient. I had bought the overpriced ~$85 VW replacement hose part number 1K0612041GQ but had not yet installed it because it had appeared that my fix had been working. Today I finally installed the official part and voila, the delayed brake release problem is completely gone. Other than a broken radio code, my 2006 Jetta TDI is now working perfectly, throwing zero codes and is again a joy to drive. I still do not understand why a slight vacuum leak in that hose would cause the problem I encountered, but by all appearances, that is exactly what happened.
 

Rx7145

Veteran Member
Joined
May 21, 2017
Location
Ohio
TDI
2006 Jetta BRM
Was there any kind of check valve in the original hose? But the brakes are very sensitive to vacuum leaks. I had a small vacuum leak and the brakes were noticeably spongy after two or three applications.
 

sptsailing

Veteran Member
Joined
Jul 9, 2010
Location
Safety Harbor, FL
TDI
2006 Jetta Manual, stock with Panzer Plate & Franko6 modified EGR cooler & CAM
The check valve in the original hose worked fine. The leak was in between the check valve and the vacuum pump. This also means that the vacuum operating the boost has been less than it should have been for quite awhile too.
 
Top