2000 MKIV Oil Light Flashing

ajcook5

Well-known member
Joined
Nov 18, 2011
Location
Wisconsin
TDI
2000 Jetta
Hey everyone, question for ya. My oil light came on and started flashing at me today. Oil level is good and it only comes on and flashes when I hit 2000rpm and then goes away after returning to idle. Oil changed 200 miles ago with Rotella T4 15w40. I would pressure test it but I don't currently have an oil pressure gauge. Has anyone had this issue? Common causes? Any input helps, thanks!

2000 MKIV Manual Jetta TDI 392k
 

Vince Waldon

Top Post Dawg
Joined
Apr 25, 2009
Location
Edmonton AB Canada
TDI
2001 ALH Jetta, 2005 BEW Wagon
Oil pressure is not monitored by the system below 2000 RPM, so that's why the light only comes on then.

Could be a sensor issue but could also be an actual pressure problem, so unless a visual inspection reveals an obvious broken wire at the sensor (side of the oil filter housing) the safe thing to do is to park the car until you can get a pressure gauge on it and figure out which bucket the problem is in.

That said, not uncommon for the sensor to fail and many folks just shot-gun it to see if that fixes the issue. The pump itself is pretty robust but the drive chain can break or the pickup clog.

If you *do* have low oil pressure the turbo life is measured in minutes, with the main bearings not much farther down the road.
 

Midwesthick

Veteran Member
Joined
Oct 26, 2011
Location
Denver
TDI
A6, Q5, Golf
Silly question but was this before the motor being warmed up or was it cold outside?

In negative temps, I had mine come on and flash at me on the occasion. With my frostheater it never happened again.
 

Sauaciden

Veteran Member
Joined
Oct 4, 2019
Location
Lithuania
TDI
A3 8L 1.9TDI
Silly question but was this before the motor being warmed up or was it cold outside?

In negative temps, I had mine come on and flash at me on the occasion. With my frostheater it never happened again.
It is possible that it depends on oil type. Never had oil light come on when using 5w40 during the winter (-25c)
 

ajcook5

Well-known member
Joined
Nov 18, 2011
Location
Wisconsin
TDI
2000 Jetta
Thanks for the input guys, this did happen when it was cold outside. I don't have an oil pressure tester readily available so I pulled the sensor and did a continuity / resistance test on it and it failed. Just installed the new one and seems to have fixed the issue. May do a pressure test on it anyway once I get my hands on the tester.
 

Vince Waldon

Top Post Dawg
Joined
Apr 25, 2009
Location
Edmonton AB Canada
TDI
2001 ALH Jetta, 2005 BEW Wagon
FWIW and just as a datapoint, I can't think of any reason why it would be normal for the oil light to come on with a cold but healthy engine. :) If anything the oil pressure will be the highest with the engine cold.... the oil is thicker and bearing clearances are smaller.

Edit: one reason does occur to me, at least an oil light during cranking a cold engine. VW's oil pressure warning system ignores oil pressure for the first 5-10 seconds of cranking and then engages. If for some reason the engine is still cranking at this point the oil pressure will be low (engine at 200-300RPM rather than idle) and the warning system will complain.

Still can't think of any routine reason for a low pressure light on a running cold engine though. :)
 

ajcook5

Well-known member
Joined
Nov 18, 2011
Location
Wisconsin
TDI
2000 Jetta
Update: car is running fine, no more oil light. Did an oil pressure test last night anyway, pressure fell within specs.
 
Top