www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums Articles Links Meets
Orders TDI Club Cards TDIFest 2014 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You



Go Back   TDIClub Forums > TDI Model Specific Discussions Areas > VW MKIV-A4 TDIs (VE and PD)

VW MKIV-A4 TDIs (VE and PD) This is a general discussion about A4/MkIV Jetta (99.5-~2005), Golf(99.5-2006), and New Beetle(98-2006). Both VE and PD engines are covered here.

Reply
 
Thread Tools
Old September 10th, 2004, 15:22   #1
KamFong
Newbie
 
Join Date: Jul 2004
Location: Western Mass
TDI(s): 2003 Jetta
Default 20 feet, no throttle... DTC 16612

So I recently installed some wiring and accidently disconnected the positive terminal of the battery. Now, about 1 minute or so after turning on the car (don't even have to start the engine) the glow plug light flashes and the check engine light comes on. The car will drive about 20 feet and stop. Engine continues to idle, but the throttle acts as if I took my foot off the pedal. Wait a couple seconds, and I can drive another 20 feet before the same thing happens.

VAG-COM shows the following fault code:

16612 - Throttle Pedal Position Sensor (G79): Signal too High
P0228 - 35-00 - -

Any thoughts? Dealer says I need to reset the basic settings and let the car re-learn itself. I'm skeptical.
KamFong is offline   Reply With Quote
Old September 11th, 2004, 12:28   #2
Curious Chris
Veteran Member
 
Join Date: Jun 2001
Location: Indianapolis, IN
Fuel Economy: 47/42/38
Default 20 feet, no throttle... DTC 16612

Well it could be confused so you do this:

Note: Channel 00 is a special case. Performing a [Save] to Channel 00 resets all adaptation values to their original factory defaults. This only works in controllers that support this function, see your Factory Repair Manual to find out if this procedure applies to each controller in your vehicle.

Assuming you have VagCom it is a easy thing to try.
Curious Chris is offline   Reply With Quote
Old September 15th, 2004, 16:38   #3
KamFong
Newbie
 
Join Date: Jul 2004
Location: Western Mass
TDI(s): 2003 Jetta
Default 20 feet, no throttle... DTC 16612

Can you explain how to perform the Save for channel 00 with VAG-COM? Has anyone tried this? From the Ross-Tech site, it's not clear that this will work for a TDI and I'd rather not mess something up.
KamFong is offline   Reply With Quote
Old September 20th, 2004, 12:33   #4
KamFong
Newbie
 
Join Date: Jul 2004
Location: Western Mass
TDI(s): 2003 Jetta
Default 20 feet, no throttle... DTC 16612

Turns out to have been some damaged wiring from where I sent the switch wire through the firewall. Dealer replaced throttle pedal as well under warranty (replaced wiring cost $165).
KamFong is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:56.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2014
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
1996 - 2013, All Rights Reserved
Page generated in 0.12520 seconds with 9 queries
[Output: 56.62 Kb. compressed to 50.37 Kb. by saving 6.25 Kb. (11.04%)]