www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums Articles Links Meets
Orders TDI Club Cards TDIFest 2016 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You




Go Back   TDIClub Forums > VW TDI Discussion Areas > TDI 101

TDI 101 Got a simple/basic TDI question? Are you a newbie (new to the forums). Feel free to post your question here.

Reply
 
Thread Tools
Old February 5th, 2018, 09:23   #1
Mawcus
Veteran Member
 
Join Date: Oct 2012
Location: Bellingham, WA
Fuel Economy: 41 mpg
Default Will plugging in a new Camshaft Position Sensor fix a G40 No Signal Fault Code

Been troubleshooting a G40 Camshaft Position Sensor No Signal fault code. Wondering if just plugging in a brand new sensor as a quick test will make the fault code go away or does the CPS need to be completely installed and in place for the fault code to go away.
__________________
Mawcus is offline   Reply With Quote
Old February 5th, 2018, 11:25   #2
JB05
Veteran Member
 
Join Date: Oct 2005
Location: Il.USA
Fuel Economy: 43/41/40
Default

Yes, it would have to be installed properly. It's a hall -effect type sensor according to the PDF that was linked here just yesterday. The ears on the cam sprocket is what triggers the signal.
JB05 is offline   Reply With Quote
Old February 5th, 2018, 21:45   #3
Franko6
 
Join Date: May 2005
Location: Sw Missouri
Default

First, make sure you aren't out of range. The cam positioner will go '0', no read if that is the case. Also, BEW's are notorious for losing the ground from the cam position sensor to the ECU. It's the brown wire.
__________________
Frank's VW TDI's, LLC
1007 Olive St.
Lockwood, MO 65682
417-232-4634
FranksTDIs@sbcglobal.net

'02 80k grey leather, 99.5 R.I.P 153k
'85A2 NA 375k, '91 A3 290k Always Silver, Always a Jetta
Franko6 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TB Change No Start and VCDS Code P3008 19464 - Camshaft Position Sensor (G40) armyschus VW MKIV-A4 TDIs (VE and PD) 2 July 15th, 2017 18:18
Camshaft Position Sensor (G40): Signal Out of Range arron9999 VW B5 Passat TDIs 5 December 28th, 2016 18:37
16725 - Camshaft Position Sensor (G40) P0341 - 000 - Implausible Signal lirunaway VW MKIV-A4 TDIs (VE and PD) 0 June 2nd, 2012 21:50
Camshaft Position Sensor (G40): No Signal lirunaway VW MKIV-A4 TDIs (VE and PD) 1 August 11th, 2011 18:55
19464 - Camshaft Position Sensor (G40): Signal Out of Range P3008 - 000 coalminer16 TDI 101 3 August 2nd, 2010 22:24


All times are GMT -7. The time now is 22:50.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2017
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
1996 - 2017, All Rights Reserved
Page generated in 0.13349 seconds with 10 queries
[Output: 57.51 Kb. compressed to 52.24 Kb. by saving 5.28 Kb. (9.17%)]