www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums Articles Links Meets
Orders TDI Club Cards TDIFest 2014 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You



Go Back   TDIClub Forums > TDI Model Specific Discussions Areas > VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014)

VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014) Discussions area for A6/MkVI (2010-2014) Golf and Golf Wagons (Jetta Sportwagon in the USA).

Reply
 
Thread Tools
Old November 14th, 2013, 14:21   #1
mimmik
Member
 
Join Date: Nov 2009
Location: colorado (boulder area)
Default 2010 JSW check engine/glow plug lights, codes P0045 & P0047

Hi to all - I searched the forum a bit and didn't come up with much (and am a bit of a TDI beginner anyway) so I'm hoping for some advice.

I have a 2010 JSW (manual & 34,150 miles and about 8 months after the 3yr warranty ended) and the check engine light and blinking glow plug light came on a few nights ago after driving for apx 30min. I was about a mile from home so kept going and noticed nothing different except for no 'oomph' - is that what is called limp mode? There is no real acceleration, though I didn't push it and I'm not driving it except back from the dealer and to another garage (about 2 miles).

With much grumbling, my local dealer agreed to scan it for free (they wanted me to pay $112 to scan it and diagnose) and they came up with codes P0045 & P0047. The tech was really nice and thought it might be a wiring/connection issue (i.e. chewed through by a rodent, etc), but of course couldn't really say for sure. I know the codes have to do with the turbocharger/solenoid from this site http://www.carobdcode.com/p0045-volk...ontrol-circuit, but it only talks about the CEL and not the blinking glow plug light. I did confirm both brake lights are working.

Anyone with similar experiences or have an idea of what it might be? I'm not excited about forking out a lot of $ now that the 3yr warranty is up, so I'm hoping whatever it is may still be under the 5yr warranty (my ignorance of car stuff shows here). The dealer said if the problem is wiring then it would not be covered. I have checked with the 2 nearby Colorado TDI gurus from your list (Anuthee and Frey's Foreign Cars) and they are both very booked, so I'd be without a car for a lot longer than I would be if the dealer worked on it. No good answer.

For some background in case it's related, they did replace my HPFP (twice) just over a year ago after I started hearing a strange sound (kind of a metallic 'whooshing/scraping' from the front end through the air vents), and since I bought the car new in 2010 I've had the repeated 'hiccup'/hesitation around 2000rpm, which I posted about a year ago or so. I still have both issues but have been told that they are likely just 'characteristics' of the car and are probably nothing.

Thanks and let me know if I can provide any more info and I will if I can!

Last edited by mimmik; November 14th, 2013 at 14:24.
mimmik is offline   Reply With Quote
Old November 18th, 2013, 18:15   #2
mimmik
Member
 
Join Date: Nov 2009
Location: colorado (boulder area)
Default

Ended up having the dealer do a diagnosis today and they say they 'found a broken wire inside the wiring connector for turbo wastegate solenoid valve. They need to re-pin the wire into the connector housing. The estimate is $142.00 + taxes and shop supplies.'

Bummer that it is wiring since that isn't covered anymore. Bummer that a car that isn't even 4 yrs old already has a broken wire - how does that happen??

Am planning on letting them do the work unless anyone who happens to read this tonight and thinks otherwise?
mimmik is offline   Reply With Quote
Old November 18th, 2013, 22:58   #3
jahlov420
Veteran Member
 
Join Date: May 2012
Location: Richmond Va
Fuel Economy: 40 mpg combo driving
Default

i had the same type of thing happen. it was two tiny wires that went to this solenoid valve. one of them was broken. the part was about 10 bucks from the dealer and i did it myself.

p.s. my friend used to work there and they scanned it for free and the guy just told me what to do.
__________________
jahlov420 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flashing Glow Plug/ Check Engine Lights shiggs101 VW MKV-A5 Golf/Jettas 8 August 3rd, 2012 21:51
Glow Plug and Check Engine lights question cdnalpina TDI 101 8 September 23rd, 2009 10:18
Check engine & glow plug lights, what does it mean? Karen Abse VW MKIII-A3/B4 TDIs 6 February 10th, 2006 07:52
Engine & Glow plug lights on dec942 TDI Power Enhancements 6 November 2nd, 2005 16:02
Glow Plug lights blinking and now Check engine Got Haggis? VW MKIV-A4 TDIs (VE and PD) 6 May 24th, 2004 10:26


All times are GMT -7. The time now is 01:04.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2014
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
1996 - 2013, All Rights Reserved
Page generated in 0.11801 seconds with 10 queries
[Output: 58.96 Kb. compressed to 53.59 Kb. by saving 5.38 Kb. (9.12%)]