www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums Articles Links Meets
Orders TDI Club Cards TDIFest 2014 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You



Go Back   TDIClub Forums > VW TDI Discussion Areas > TDI 101

TDI 101 Got a simple/basic TDI question? Are you a newbie (new to the forums). Feel free to post your question here.

Reply
 
Thread Tools
Old May 9th, 2011, 15:23   #1
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default RPM going up and down at constant speed HELP!!

Just got my other TDI up and going (2002 Jetta). My problem is at about 1500 to 3000 RPM's while driving at a constant speed (not slowing down or accelerating) my RPM's will go up and down about a 100 or so, causing the car to what i would say rock. I have VCDS and the only code i have is: "Anti-Shudder Valve + or - ground Intermittent" I've looked at all the write ups on this code, i have replaced all my vacuum lines and checked/cleaned the connector to the anti-shudder valve but still the code doesn't go away or the RPM problem. Car runs and drives great with the exception of this problem, anyone have any ideas?

Thanks
Josh
cgi2099 is offline   Reply With Quote
Old May 9th, 2011, 15:25   #2
alphaseinor
 
Join Date: Jul 2006
Location: Frisco, TX
Fuel Economy: 35 in city floored, 48 on highway @75mph
Default

Try unplugging your electrical connector to the antishutter valve control, it's the little black box on the back of the intake manifold... kinda hidden.
alphaseinor is online now   Reply With Quote
Old May 9th, 2011, 15:37   #3
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default

Do i leave it unplugged?
cgi2099 is offline   Reply With Quote
Old May 9th, 2011, 15:39   #4
alphaseinor
 
Join Date: Jul 2006
Location: Frisco, TX
Fuel Economy: 35 in city floored, 48 on highway @75mph
Default

sure, just for the test...

on a 99.5 it should be a squeeze on the two wires, then pull.
alphaseinor is online now   Reply With Quote
Old May 9th, 2011, 15:52   #5
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default

okay thanks ill give that a try.
cgi2099 is offline   Reply With Quote
Old May 10th, 2011, 08:53   #6
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default

I unplugged the sensor and it didn't help, still the same problem.
cgi2099 is offline   Reply With Quote
Old May 10th, 2011, 08:59   #7
99vdub
Newbie
 
Join Date: Apr 2011
Location: San Leandro California
TDI(s): 99 mk4 jetta
Default

I have that same problem on my 99.5 as well, it just started this past weak. It all started with a permanent CEL and blinking GPL for a whole day than the next morning it went away. All of a sudden speedometer and RPM started bouncing freely and I get this shudder in second gear at about 20-25 miles per hour, I can hear a noise near the dashboard Im not sure if its related to my problem.
99vdub is offline   Reply With Quote
Old May 10th, 2011, 09:04   #8
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default

My speedo doesn't move around its just the RPM's going up and down at a constant speed, i also don't have any noise from the dashboard.
cgi2099 is offline   Reply With Quote
Old May 10th, 2011, 11:03   #9
procupine14
Veteran Member
 
Join Date: May 2010
Location: Kansas City, MO
Default

Well, you say it is a 2002 are you perhaps running with an automatic I didn't see where you said either way on that.
__________________
procupine14 is offline   Reply With Quote
Old May 10th, 2011, 13:01   #10
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default

I'm sorry i didn't include that in my first post, but yes it is an automatic?
cgi2099 is offline   Reply With Quote
Old May 10th, 2011, 13:22   #11
procupine14
Veteran Member
 
Join Date: May 2010
Location: Kansas City, MO
Default

If it is an automatic I'm thinking your surging is coming from the valve body. I would recommend talking to CoolAirVW on this site about diagnosing this thing for sure and, if it is what I think it is, replacing the valve body with a rebuild one before it wrecks the rest of your tranny.

http://kansascitytdi.com/

there is a link to his site and also there is a 01M FAQ on there where you might find extra help with your issue.
__________________
procupine14 is offline   Reply With Quote
Old May 10th, 2011, 15:27   #12
cgi2099
Veteran Member
 
Join Date: Aug 2010
Location: Oklahoma
TDI(s): Jetta 1999.5
Fuel Economy: 45
Default

okay i just sent him a pm
cgi2099 is offline   Reply With Quote
Old September 3rd, 2011, 00:27   #13
fakhan
Newbie
 
Join Date: Feb 2011
Location: Los Angeles
TDI(s): Jetta
Default

Hello,
Some one help my jetta 2002 tdI starting normal but when I put in gear and try to drive rpm goes up and down and some back fire kind think happened also black smog coming out if I take out the air senssor car start drive normal no black smog but some funny sound come from engin I already clean intake egr valve still same....
Thanks
fakhan is offline   Reply With Quote
Old September 3rd, 2011, 03:46   #14
RECCE-17
Veteran Member
 
RECCE-17's Avatar
 
Join Date: Oct 2010
Location: Prince Edward Island, Canada
Fuel Economy: 37/40/45
Default

Quote:
Originally Posted by fakhan View Post
Hello,
Some one help my jetta 2002 tdI starting normal but when I put in gear and try to drive rpm goes up and down and some back fire kind think happened also black smog coming out if I take out the air senssor car start drive normal no black smog but some funny sound come from engin I already clean intake egr valve still same....
Thanks
Try getting a new MAF. Also try not to hijack anyone's thread again. Sorry but if you have a problem start your own thread.

As for the OP problem sounds like the transmission to me as well. The ASV code may just be a coincidence. Your sure the ASV arm is still working not broken?
__________________

Through the mud and the blood to the green fields beyond. RCAC.
RC2, VNT 17, 11mm IP, Koni Red's, EGR cooler delete, TT bushings, Hidden hitch, 5 light mod, Evolution skid plate (with oil drain).
RECCE-17 is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 jetta stuttering at constant speed volksman1950 VW MKIV-A4 TDIs (VE and PD) 10 April 7th, 2011 22:12
SGII Constant speed MPG dremd TDI Fuel Economy 20 October 11th, 2007 09:28
small rpm changes while driving at constant speed truav8r VW MKIV-A4 TDIs (VE and PD) 10 July 10th, 2007 23:18
Constant speed, best MPG guidelines Andrei Rinea TDI Fuel Economy 10 January 14th, 2003 09:29
constant speed DieselDrinker TDI 101 5 November 21st, 2001 04:07


All times are GMT -7. The time now is 13:30.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2014
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
Đ 1996 - 2013, All Rights Reserved
Page generated in 0.15895 seconds with 10 queries
[Output: 113.97 Kb. compressed to 94.92 Kb. by saving 19.05 Kb. (16.71%)]