www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums TDIFAQ Articles Links Meets
Orders TDI Club Cards TDIFest 2014 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You



Go Back   TDIClub Forums > VW TDI Discussion Areas > TDI 101

TDI 101 Got a simple/basic TDI question? Are you a newbie (new to the forums). Feel free to post your question here.

Reply
 
Thread Tools
Old February 20th, 2008, 18:54   #1
SmudgePot
Member
 
Join Date: Feb 2008
Location: Kansas City, KS
Fuel Economy: 40.15 ---- so far
Default Cruise Control not working ...... any ideas or suggestions

I have a 2002 Jetta automatic. The cruise control quit working. When I switch the cruise to the on position it lights up a cruise lamp on the dash but when I push the set or resume button .... nothing happens.

Any help would be appreciated.

Thanks
SmudgePot
SmudgePot is offline   Reply With Quote
Old February 20th, 2008, 19:02   #2
tomo366
TDI Lifer
 
tomo366's Avatar
 
Join Date: Jun 1997
Location: Kensington, Maryland USA
Fuel Economy: Old Passat 40 Mercedes 20
Default

Replace the Brake light switch
__________________

2013 Jetta Hybrid SEL Premium Frost Silver/Titan Black
1996 Passat TDI Storm Grey
1984 Mercedes 300D Blue/Green
tomo366 is offline   Reply With Quote
Old February 20th, 2008, 19:24   #3
Cas
Veteran Member
 
Join Date: Jan 2006
Location: Chicagoland
TDI(s): 2009jetta
Default

i cleaned the contacts by removing slide button with small screw driver,spray electric cleaner . working fine now
Cas is offline   Reply With Quote
Old February 20th, 2008, 20:52   #4
02AutoWag
Veteran Member
 
Join Date: Apr 2005
Location: Vacaville, CA
Default

I'd like to add my cruise control problem to this thread too...
-2000 Golf with automatic trans and 123,000 miles, has never worked while in my possession (last 5K miles).
-Unlike SmudgePot, my dash light does not come on when I slide the switch.
-My brake switch was recently replaced (brake lights work, but still no cruise function).
-I checked via Vag-Com and the Cruise function is coded properly.

Now on to the proposed fix...
-How do you remove the slide button? Which way do you pry?
__________________
Russ
2002 Jetta Wagon (auto)
2000 Golf (5-speed swapped)
FOR SALE:
1998 New Beetle (minus 5-speed trans parts)
02AutoWag is offline   Reply With Quote
Old February 21st, 2008, 11:27   #5
KROUT
persona non grata
 
Join Date: Aug 2005
Location: JAX FL
Default

When I bought my jetta the ecu had been reflashed by the dealer and the cruise was turned off. I cant remember what I did to turn it back on but did it with vag-com. I fould the info to check it here. Sorry dont have any links.
KROUT is offline   Reply With Quote
Old February 21st, 2008, 12:24   #6
jcrews
Veteran Member
 
jcrews's Avatar
 
Join Date: Jul 2007
Location: Round Rock, TX - VCDS
TDI(s): 2003 Golf
Default

Did you remember... to check all of your fuses....?

They get me every time
jcrews is offline   Reply With Quote
Old February 21st, 2008, 14:01   #7
jettawreck
Veteran Member
 
jettawreck's Avatar
 
Join Date: Aug 2004
Location: Northern Minnesota-55744
Fuel Economy: 52+ average lifetime '01
Default

Sometimes even if the brakelight switch is ok a burnt out taillight/brakelight bulb will do it. Odd, but....
__________________

2001 Jetta TDI GLS Silver-current driver (salvage)permanently vented-Panzer Plate-Sprint 520s-ScanGauge-CheckTemp III-ZeroStart heater-CAT 2 filter
2003 Jetta GLS Black w/leather (New Project Car) fixer-upper w/broken TB
2004 Cadillac SLS (wife's)
1999 GMC Suburban (It's MN-you need one)
197? Shibura 2cyl diesel 4WD tractor-loader/brushhog (very handy unit)
196? International TD340 Dozer-w/Drott 4-in-1 bucket/back ripper attachment
jettawreck is offline   Reply With Quote
Old February 21st, 2008, 15:16   #8
SmudgePot
Member
 
Join Date: Feb 2008
Location: Kansas City, KS
Fuel Economy: 40.15 ---- so far
Default

Yep, I checked all the fuses. I did have a tail light bulb out but I replaced it, didn't fix the problem. I will try the brake light switch next and clean the contacts in the on/off switch. I am not sure how to disassemble the switch tho.
Thanks for all the ideas.
__________________
2002 Jetta Automatic
130,318 miles
40 MPG Avg Highway
No mods.....yet
SmudgePot is offline   Reply With Quote
Old February 22nd, 2008, 04:59   #9
TDIFanatic1.9
Veteran Member
 
Join Date: Jan 2007
Location: South Africa
Default

There was a thread about the actual switch on the flicker stalk that needed cleaning. You need to carefuly remove the sliding button and spray some switch cleaner in there.
__________________
2003 Jetta4 tdi non-pd 110hp
TDIFanatic1.9 is offline   Reply With Quote
Old February 22nd, 2008, 09:33   #10
02AutoWag
Veteran Member
 
Join Date: Apr 2005
Location: Vacaville, CA
Default

Quote:
Originally Posted by 02AutoWag
I'd like to add my cruise control problem to this thread too...
-2000 Golf with automatic trans and 123,000 miles, has never worked while in my possession (last 5K miles).
-Unlike SmudgePot, my dash light does not come on when I slide the switch.
-My brake switch was recently replaced (brake lights work, but still no cruise function).
-I checked via Vag-Com and the Cruise function is coded properly.

Now on to the proposed fix...
-How do you remove the slide button? Which way do you pry?
I suppose I should have searched first ...
http://forums.tdiclub.com/showthread.php?p=825571

-Looks like my 2000 does not have a dash light, so that explains that.
-I'll have to give the Vag-Com another try as I don't think I went through the whole test procedure.
-Slide switch removal picture included in link above.
__________________
Russ
2002 Jetta Wagon (auto)
2000 Golf (5-speed swapped)
FOR SALE:
1998 New Beetle (minus 5-speed trans parts)
02AutoWag is offline   Reply With Quote
Old February 24th, 2008, 15:46   #11
02AutoWag
Veteran Member
 
Join Date: Apr 2005
Location: Vacaville, CA
Default

Quote:
Originally Posted by 02AutoWag
I suppose I should have searched first ...
http://forums.tdiclub.com/showthread.php?p=825571

-Looks like my 2000 does not have a dash light, so that explains that.
-I'll have to give the Vag-Com another try as I don't think I went through the whole test procedure.
-Slide switch removal picture included in link above.
The Vag-Com testing using the link above showed that my switch wasn't working properly. As instructed, I popped the slide switch off and sprayed a little electronics cleaner...cruise now functions as expected. Thanks Wingnut for the pictorial.

If you don't have Vag-Com, I'd suggest just prying the switch and giving the cleaner a try. The switch attaches just like a snap button on a pair of pants or a jacket, so there's not much that can go wrong.
__________________
Russ
2002 Jetta Wagon (auto)
2000 Golf (5-speed swapped)
FOR SALE:
1998 New Beetle (minus 5-speed trans parts)

Last edited by 02AutoWag; February 24th, 2008 at 15:49.
02AutoWag is offline   Reply With Quote
Old March 7th, 2008, 21:04   #12
SmudgePot
Member
 
Join Date: Feb 2008
Location: Kansas City, KS
Fuel Economy: 40.15 ---- so far
Default

I checked the fuses, changed the brake light switch and cleaned the contacts as suggested with no positive results, my cruise still doesn't work. Any other suggestions would be appreciated.

PS: The VW cruise control system is different than any other I have I have seen so suggestions and hints are greatly appreciated.
__________________
2002 Jetta Automatic
130,318 miles
40 MPG Avg Highway
No mods.....yet
SmudgePot is offline   Reply With Quote
Old March 7th, 2008, 21:07   #13
compu_85
Gadget Guy
 
compu_85's Avatar
 
Join Date: Sep 2003
Location: Springfield VA
Fuel Economy: 56.3/44/41
Default

I would get a proper scan tool and ask the computer about the status of the switches.

-Jason
__________________
Present:
2012 Passat SE TDI DSG. 60,000 miles. Factory Alarm, LED tails, Memory Seat, HIDs 38/48 MPG.
99.5 Jetta "GLX" TDI. 295,000 miles. Half way there!!! Power Memory Seats, HIDs 11mm pump, BV39 Turbo, RCIII 36/47 MPG.
1991 Mercedes 350SDL 230,000 miles, 70,000 on engine. 18/27 MPG.
Past:
1988 Audi 5000S Quattro, 1992 Jetta ECOdiesel, 1991 Jetta ECOdiesel.

Check out the official TDIClub Chat Room!
Quote:
Originally Posted by BRUSSELS BELGIAN View Post
Maybe I should pay MYSELF to do bad work on my car!
compu_85 is offline   Reply With Quote
Old March 8th, 2008, 15:46   #14
SmudgePot
Member
 
Join Date: Feb 2008
Location: Kansas City, KS
Fuel Economy: 40.15 ---- so far
Default

I have been wondering about that. What is a proper scan tool? Is there something other than the Ross that works well? It would be nice to have some kind of hand held unit if there is anything that works well.
__________________
2002 Jetta Automatic
130,318 miles
40 MPG Avg Highway
No mods.....yet
SmudgePot is offline   Reply With Quote
Old March 8th, 2008, 18:43   #15
02AutoWag
Veteran Member
 
Join Date: Apr 2005
Location: Vacaville, CA
Default

Only the Ross-Tech Vag-Com cable and software will give you access to the necessary test screens. Check the regional forums to see if you can meet with someone who has the cable and is willing to help you. http://forums.tdiclub.com/forumdisplay.php?f=34
__________________
Russ
2002 Jetta Wagon (auto)
2000 Golf (5-speed swapped)
FOR SALE:
1998 New Beetle (minus 5-speed trans parts)
02AutoWag is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 22:05.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2014
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
1996 - 2013, All Rights Reserved
Page generated in 0.15466 seconds with 9 queries
[Output: 122.49 Kb. compressed to 101.34 Kb. by saving 21.15 Kb. (17.27%)]