www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums TDIFAQ Articles Links Meets
Orders TDI Club Cards TDIFest 2014 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You



Go Back   TDIClub Forums > TDI Model Specific Discussions Areas > VW MKIV-A4 TDIs (VE and PD)

VW MKIV-A4 TDIs (VE and PD) This is a general discussion about A4/MkIV Jetta (99.5-~2005), Golf(99.5-2006), and New Beetle(98-2006). Both VE and PD engines are covered here.

Reply
 
Thread Tools
Old May 23rd, 2007, 08:36   #1
thermo
Member
 
thermo's Avatar
 
Join Date: Nov 2006
Location: Ellington, CT
Default Odometer comes and goes

On my 2000 Jetta (mkIV) TDI,
my odometer doesn't display any data when it's cold outside, or even cool.
When warm enough, the milage appears. The clock always works as does the trip meter. It's just the odometer that has this problem.
As things warm up, more and more digits appear. After sitting in the parking lot all day and getting nice and hot all digits appear in full LCD glory.

I browsed through some other posts on this and it sounds like it could be the "zebra" contacts behind that display element. I guess that means that there is a separate one for the trip meter?

One day I removed the cluster from the dash, but it didn't appear to be very serviceable so i put it back in. I made sure that the wiring harnesses were fitted on properly.

I was turned away from an emission test this morning because they couldn't read the odometer. Very frustrating. I rescheduled the test for an afternoon so that the car will be hot inside and the display should be back on.

I'd like to fix this. Can anyone recomend something aside from replacing the cluster? How much does another cluster cost anyway?

Thanks,
Thermo
thermo is offline   Reply With Quote
Old July 11th, 2007, 17:59   #2
PD2004
Member
 
Join Date: Jun 2004
Location: Denton, TX
Default

Any luck with this? I recently had my clock and tripmeter act up....
__________________
Chris.
'04 Platinum Grey Jetta GLS TDI 5 spd (CAT2 filter, E-codes, Phatnoise, still waiting on CCV filter and EGR mod info...)
PD2004 is offline   Reply With Quote
Old July 29th, 2007, 12:30   #3
Wook660
Veteran Member
 
Wook660's Avatar
 
Join Date: Aug 2005
Location: Colchester, CT
Fuel Economy: 48 mpg
Default

I'm gonna refresh this...

I went to a wedding yeturday and my display was working perfectly, came back out to the car about an hour later and the display was almost gone. Only the top 1/3 of the numbers on the odometer is visible and the clock and tripometer are gone. This morning everything was completely blank but after driving maybe 5 minutes the top 1/3 appeared again. Any suggestions, I'm in FL so the cold obviously has nothing to do with it. Is it only fixable with a whole new cluster, thanks.
__________________
2002 Jetta TDI AT Sold.
2001 Jetta TDI MT going the distance! - 301K...
1988 Samurai, soon to be diesel?
Mahindra 4530 Diesel!
Wook660 is offline   Reply With Quote
Old December 16th, 2009, 11:08   #4
LPC
Veteran Member
 
Join Date: Dec 2006
Location: GA
Default

Any ideas on this? My odometer digits are going out when cold outside, notice in the morning. They are back when warm out on drive home. My mile counter is also doing the same. My clock has not had this problem, but my speedometer and tacometer needle lights are not working. Is all this just start of display going out? Im over 200K miles....
__________________
2001 Jetta TDI 203K miles. Driving
2003 Jetta TDI 135K miles. (sold)
2000 Jetta TDI 220K miles. wrecked now parts car
1998 Beetle TDI 121K miles (sold)
1997 Jetta TDI 215K miles. (sold)
LPC is offline   Reply With Quote
Old December 16th, 2009, 11:10   #5
LPC
Veteran Member
 
Join Date: Dec 2006
Location: GA
Default

Just noticed the date on the last post. Sorry on pulling this old thread up. Any other threads with resolution. My searches are not bringing anything else up.....
__________________
2001 Jetta TDI 203K miles. Driving
2003 Jetta TDI 135K miles. (sold)
2000 Jetta TDI 220K miles. wrecked now parts car
1998 Beetle TDI 121K miles (sold)
1997 Jetta TDI 215K miles. (sold)
LPC is offline   Reply With Quote
Old January 12th, 2010, 08:56   #6
thermo
Member
 
thermo's Avatar
 
Join Date: Nov 2006
Location: Ellington, CT
Default

still having the problem after all this time.
Trip meter and clock work perfectly, but odometer won't appear unless its really warm inside the car.

the cluster is a single unit and doesn't appear to be serviceable. I read that if you replace the cluster, the odometer reading gets reset.

I guess we all have to live with it as it is.
thermo is offline   Reply With Quote
Old February 19th, 2012, 18:32   #7
thermo
Member
 
thermo's Avatar
 
Join Date: Nov 2006
Location: Ellington, CT
Default

I recently fixed this. Will try to follow up with post ... until them feel free to PM me.
thermo is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:10.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2014
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
1996 - 2013, All Rights Reserved
Page generated in 0.15253 seconds with 9 queries
[Output: 74.67 Kb. compressed to 64.17 Kb. by saving 10.49 Kb. (14.05%)]