www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums Articles Links Meets
Orders TDI Club Cards TDIFest 2016 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You

Order your TDIClub merchandise and help support TDIClub


Go Back   TDIClub Forums > TDI Model Specific Discussions Areas > VW MKIV-A4 TDIs (VE and PD)

VW MKIV-A4 TDIs (VE and PD) This is a general discussion about A4/MkIV Jetta (99.5-~2005), Golf(99.5-2006), and New Beetle(98-2006). Both VE and PD engines are covered here.

Reply
 
Thread Tools
Old July 24th, 2018, 21:04   #1
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default no check engine light or glow plug light on 2003 tdi golf 1.9

the lights never come on when I turn the key on, the car runs fine.
I am new and a bit lost on this site, I have a 2003 tdi 1.9 golf gl I have failed smog due to the fact the check engine light does not come on at all, the car runs great no issues also i do not see the the glow plug light either.
I live in Ventura,CA
I was told to go to the dealer and take all my keys and have a new cluster installed and they will match the keys to the cluster.


the car runs great just can not pass a smog as if the check engine light does not come on when the key is turned it is an automated fail.

Any help would be greatly appreciated.
gayle i

Last edited by gayle; August 11th, 2018 at 20:16.
gayle is offline   Reply With Quote
Old July 24th, 2018, 21:26   #2
Vince Waldon
Veteran Member
 
Vince Waldon's Avatar
 
Join Date: Apr 2009
Location: Edmonton Alberta Canada
Default

Every once in a while we see a cluster where a previous owner has covered the Check Engine light with black electrician's tape... usually after deleting the EGR would be my guess.

Doesn't explain the missing glow plug light but might be worth a quick look just to confirm. Actually swapping a cluster is a bit of work, be nice if it was something simpler than than.
__________________
Vince Waldon Edmonton AB Canada

Note: The above is to the best of my knowledge- but at the end of the day simply interweb opinion, worth EXACTLY what you paid for it, and if used done so at your own risk.
Vince Waldon is offline   Reply With Quote
Old July 24th, 2018, 21:54   #3
caideN
Member
 
Join Date: Dec 2017
Location: CA
Default

Not sure about VWs but I remember looking at an old Honda Civic for sale 10 years ago and the owner actually took out the bulb for the CEL. Shady...
caideN is offline   Reply With Quote
Old July 28th, 2018, 08:20   #4
TDI-WNC
Newbie
 
Join Date: Jun 2018
Location: WNC
Default

Relay 109 caused that on my 2000 Jetta... but it wouldn't start, as it also controls the fuel shutoff solenoid on the injector pump.
TDI-WNC is offline   Reply With Quote
Old July 28th, 2018, 19:04   #5
wonneber
Veteran Member
 
Join Date: Oct 2011
Location: Monroe, NY, USA
Default

The light seems to be part of the control module. Does not look like it's replaceable.
Check fuses 11 15 and 10. They all provide power to the control module.
Long shot. Check if power is getting to pins 1 23 and 30 on the module.
wonneber is offline   Reply With Quote
Old July 29th, 2018, 16:24   #6
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

thank you so very much I will have those fuses checked.
what size fuse goes in the 32 slot on the driver side panel?
gayle is offline   Reply With Quote
Old July 29th, 2018, 17:02   #7
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

what size fuses go in each?

11
15
10
gayle is offline   Reply With Quote
Old July 29th, 2018, 17:05   #8
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

what size fuses go in each?

11
15
10
gayle is offline   Reply With Quote
Old July 29th, 2018, 19:12   #9
wonneber
Veteran Member
 
Join Date: Oct 2011
Location: Monroe, NY, USA
Default

Quote:
Originally Posted by gayle View Post
what size fuses go in each?

11
15
10
11 - 5 amp
15 - 5 amp
10 - 10 amp
wonneber is offline   Reply With Quote
Old August 10th, 2018, 21:26   #10
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

I have no idea what or where the mod is
gayle is offline   Reply With Quote
Old August 10th, 2018, 21:27   #11
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

Mine runs fine.
Just need to fix it so I can have it pass the ca smog
gayle is offline   Reply With Quote
Old August 10th, 2018, 21:28   #12
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

Location: Ventura
TDI(s): 2003 vw golf gls tdi
Default
I have no idea what or where the mod is
gayle is offline   Reply With Quote
Old August 11th, 2018, 18:35   #13
wonneber
Veteran Member
 
Join Date: Oct 2011
Location: Monroe, NY, USA
Default

If I'm not mistaking its the part of the dash with the lights.
wonneber is offline   Reply With Quote
Old August 11th, 2018, 20:09   #14
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default update on cel still not working

The radio is an aftermarket radio and has a red wire in the fuse panel with and add a fuse connector and the radio works and then stops and that's that so there is a short and I think the radio is the culprit .
There is and add a fuse plugged into fuse #31 and it has two fuse piggy back on the plug this is for the radio what size fuse should be in the add a fuse?? Maybe the fuses in are wrong?
I am still going over the fuse to be sure they are all the correct ones.
\
any clues?

Still no cel spent $58.00 for them to do nothing have an appoint with the bureau of automobile to see whats up, in the mean time I have a 60 permit to drive it the tags are paid still had to pay the ca dmv.

Anyone near Ventura that has any knowledge about this please let me know.

thank all of you for all your replys.

I also have a straight exhaust if anyone is interested I am never going to use it.

Thanks again
gayle is offline   Reply With Quote
Old August 11th, 2018, 20:13   #15
gayle
Newbie
 
Join Date: Nov 2016
Location: Ventura
Default

The radio is an aftermarket radio and has a red wire in the fuse panel with and add a fuse connector and the radio works and then stops and that's that so there is a short and I think the radio is the culprit .
There is and add a fuse plugged into fuse #31 and it has two fuses piggy backed on the plug this is for the radio what size fuse should be in the add a fuse?? Maybe the fuses in are wrong?
gayle is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TDI Mystery - Flashing Glow Plug Light & Check Engine Light shmeeshma TDI 101 5 May 28th, 2018 09:46
2013 Golf glow plug light/check engine light annamei VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014) 33 October 24th, 2014 17:16
Check Engine Light and Glow Plug (?) Light appearance in 2002 Jetta JGJetta TDI 101 4 September 15th, 2014 08:49
2003 TDI Golf. check engine light on, glow plug not firing, lack of acceleration Teresa TDI 101 15 August 21st, 2011 19:25
After battery replacement, check engine light on, glow plug light flashing ... redluv VW MKIV-A4 TDIs (VE and PD) 7 June 28th, 2011 10:59


All times are GMT -7. The time now is 04:33.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2017
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
1996 - 2017, All Rights Reserved
Page generated in 0.19367 seconds with 11 queries
[Output: 118.75 Kb. compressed to 98.59 Kb. by saving 20.15 Kb. (16.97%)]