www.tdiclub.com

Economy - Longevity - Performance
The #1 Source of TDI Information on the Web!
Forums Articles Links Meets
Orders TDI Club Cards TDIFest 2016 Gone, but not forgotten VAG-Com List Unit Conversions TDIClub Chat Thank You

Order your TDIClub merchandise and help support TDIClub


Go Back   TDIClub Forums > TDI Model Specific Discussions Areas > VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014)

VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014) Discussions area for A6/MkVI (2010-2014) Golf and Golf Wagons (Jetta Sportwagon in the USA).

Reply
 
Thread Tools
Old February 18th, 2019, 08:47   #1
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default 2012 Sportwagen Radio/Bluetooth Issues

This is a goofy one and I'm willing to bet there's a simple fix, also I'm not the only one with the issue. My bluetooth radio will only play mono (single channel) and very low quality at that. I haven't found anything to adjust the quality settings in the radio itself, and adjusting them on my phone hasn't made a difference. I'm having the same issue as this guy:
https://www.reddit.com/r/Volkswagen/...te_for_rcd510/
Is there a way to do a firmware update, or some kind of massive reset for my phone/radio system? Radio model number is 1K0 035 180 AE. Any help would be great, my 2009 wagen was just totaled and this 2012 one is its replacement. It's missing some of the features I had gotten used to, but I would love it if I could get this working properly. Thanks!
Caboose is offline   Reply With Quote
Old February 18th, 2019, 10:30   #2
JELLOWSUBMARINE
Veteran Member
 
JELLOWSUBMARINE's Avatar
Default

I've been reading up on the BT modules/OE head units and they are talking about 3 different ones. 9w2, 9w3, 9x7. There is input on adding wire (stereo) upon upgrading certain models. If I'm remembering correctly the good 9w7 isn't until 2012. Interestingly my MY 11 isn't suppose to have certain features but it does.? I have a rns315 with awesome BT (phone anyways). Someone said the 315 BT was built in, some say its under the pass seat, haven't checked yet.
JELLOWSUBMARINE is offline   Reply With Quote
Old February 18th, 2019, 14:41   #3
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default

What I'm looking for now is a way to reboot/restart it. I tried restoring factory defaults and while they did get rid of a couple niggling issues I had, the BT issue remains. I don't want to tear the dash apart to power cycle it, but that's the next step if I can't find a way to soft/hard reboot it.
Caboose is offline   Reply With Quote
Old February 18th, 2019, 14:47   #4
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default

Though I bet if I just find and pull the fuse for it, that'll be as good as unplugging the back of the head. Anyone care to chime in? I'd hate to brick something because there's a footnote in italics somewhere on the bottom of a manual I don't have.
Caboose is offline   Reply With Quote
Old February 18th, 2019, 17:48   #5
ekkoh99
Veteran Member
 
Join Date: Oct 2001
Location: Wilmette, il
Default

i have a fiscon basic for sale. 50 bucks.
__________________
2005 Passat WGN TDI "Balance shaft upgrade by OilHammer on 3/27/2009" NGK-09 plugs in Jan 2011
ekkoh99 is offline   Reply With Quote
Old February 18th, 2019, 17:49   #6
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default

I don't know what that means.
Caboose is offline   Reply With Quote
Old February 18th, 2019, 20:45   #7
Sturmeyhack
Newbie
 
Join Date: Feb 2019
Location: Seattle
Default

This is a known issue. I just bought a 2012 JSW with the same head unit (RCD510) and the same issue. Itís going into the dealership later this week for a firmware flash. (My car is CPO so it comes with a warrantee.)

See technical service bulletin 2031136/2.


Sent from my iPhone using Tapatalk
Sturmeyhack is offline   Reply With Quote
Old February 18th, 2019, 21:26   #8
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default

Thanks for the info, I'll call them up tomorrow with it and see what they say.
Caboose is offline   Reply With Quote
Old February 19th, 2019, 10:49   #9
JELLOWSUBMARINE
Veteran Member
 
JELLOWSUBMARINE's Avatar
Default

Quote:
Originally Posted by Sturmeyhack View Post
This is a known issue. I just bought a 2012 JSW with the same head unit (RCD510) and the same issue. Itís going into the dealership later this week for a firmware flash. (My car is CPO so it comes with a warrantee.)

See technical service bulletin 2031136/2.


Sent from my iPhone using Tapatalk
Would the CPO warrentee cover a rns315 map update?
(2011 CPO as of 2/5/19)

thx
JELLOWSUBMARINE is offline   Reply With Quote
Old February 20th, 2019, 13:53   #10
Sturmeyhack
Newbie
 
Join Date: Feb 2019
Location: Seattle
Default

Quote:
Originally Posted by JELLOWSUBMARINE View Post
Would the CPO warrentee cover a rns315 map update?
(2011 CPO as of 2/5/19)

thx


That I donít know.


Sent from my iPhone using Tapatalk
Sturmeyhack is offline   Reply With Quote
Old February 20th, 2019, 15:38   #11
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default

They can do the update, I have it scheduled for Monday. Dude let me know up front that he can't promise it'll fix the issue, but everything I've read says that it will. $100, which is cheaper than a new radio. Thanks for all the help!
Caboose is offline   Reply With Quote
Old February 24th, 2019, 16:02   #12
Sturmeyhack
Newbie
 
Join Date: Feb 2019
Location: Seattle
Default

Follow-up: I had my RCD510 flashed at the dealership last Thursday, and it fixed the Bluetooth issue: now it plays via Bluetooth in stereo. W00t!

(This was on a 2012 JSW.)


Sent from my iPhone using Tapatalk
Sturmeyhack is offline   Reply With Quote
Old February 24th, 2019, 18:36   #13
JELLOWSUBMARINE
Veteran Member
 
JELLOWSUBMARINE's Avatar
Default

Quote:
Originally Posted by Caboose View Post
They can do the update, I have it scheduled for Monday. Dude let me know up front that he can't promise it'll fix the issue, but everything I've read says that it will. $100, which is cheaper than a new radio. Thanks for all the help!
What issue did it have 315 or 510?
__________________
JELLOWSUBMARINE is offline   Reply With Quote
Old February 24th, 2019, 18:44   #14
JELLOWSUBMARINE
Veteran Member
 
JELLOWSUBMARINE's Avatar
Default

Quote:
Originally Posted by Sturmeyhack View Post
Follow-up: I had my RCD510 flashed at the dealership last Thursday, and it fixed the Bluetooth issue: now it plays via Bluetooth in stereo. W00t!

(This was on a 2012 JSW.)


Sent from my iPhone using Tapatalk
The dealer I bought my CPO from, ran like I had the plague when I asked about updates on my 315.

My 2011 rns 315 has NON mono phone output. Do you know if the 2010 (RNS)510 is mono Phone output
__________________
JELLOWSUBMARINE is offline   Reply With Quote
Old February 24th, 2019, 18:45   #15
Caboose
Newbie
 
Join Date: Feb 2019
Location: Bellaire, Mi
Default

Quote:
Originally Posted by Sturmeyhack View Post
Follow-up: I had my RCD510 flashed at the dealership last Thursday, and it fixed the Bluetooth issue: now it plays via Bluetooth in stereo. W00t!

(This was on a 2012 JSW.)


Sent from my iPhone using Tapatalk

Thanks dude! The guy told me that they can't promise it'll fix it but I have high hopes it will.
Caboose is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Golf TDI bluetooth issues since service f1fan65 VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014) 0 September 5th, 2017 11:54
possible sportwagen purchase; bluetooth questions + ceejgee VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014) 3 May 8th, 2012 08:34
2012 Golf TDI Bluetooth issues jgoeke VW MKVI-A6 Golf family including Jetta SportWagen (~ 2010-2014) 4 March 8th, 2012 21:37
Which radio on a 2012 TDI Sportwagen? Jackmc Upgrades (non TDI Engine related) 2 November 15th, 2011 16:03
Anyone have issues w/ radio and bluetooth TDIFun4Two TDI 101 0 July 2nd, 2010 15:56


All times are GMT -7. The time now is 15:26.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright - TDIClub Online LTD - 2017
Contact Us | Privacy Statement | Forum Rules | Disclaimer
TDIClub Online Ltd (TDIClub.com) is not affiliated with the VWoA or VWAG and is supported by contributions from viewers like you.
© 1996 - 2017, All Rights Reserved
Page generated in 0.16348 seconds with 13 queries
[Output: 124.36 Kb. compressed to 103.88 Kb. by saving 20.48 Kb. (16.47%)]